Outlook 2010 won't open on Server 2012 R2 on RDS

Hi,

I have Exchange 2013 installed on a Server 2012 R2 VM

I have a RDS server working on Server 2012 R2 - Physical Server.

I have installed Office 2010 on the RDS server.

All office apps work fine apart from Outlook 2010 which will not open.

when I try to set up the outlook profile - the email details are found from AD but I then get the warning:

"Outlook cannot log on. Verify you are connected to the network and are using the proper server and mailbox name. The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action"

on the 2012 R2 RDS server I am able to connect to: https://autodiscover.DomainName.com/autodiscover/autodiscover.xml - no certificate error. I can also connect to exchange 2013 webmail on both the .local and .com addresses without certificate errors

any ideas how to solve this.

thanks

jack
LVL 1
jackbensonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Manikandan NarayanswamySecurity Specialist & IBM Security GuardiumCommented:
Hi Jack,

There is a techdoc created for resolving this issue. Please refer the below link & let me know if it helps

https://support.microsoft.com/en-us/kb/2264398
https://support.microsoft.com/en-us/kb/3032395

Thanks
Manikandan
0
jackbensonAuthor Commented:
Manikandan

thanks for your reply

(1) Encrypt data between Microsoft Outlook and Microsoft Exchange  -  was already enabled

(2) I have amended / added the registry keys. the only difference now is that

   on Windows 7 (where outlook works):
   cache - %USERPROFILE%\AppData\Local\Microsoft\Windows\Temporary Internet Files
   Cookies - C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Cookies

   on Server 2012 R2 (where Outlook 2010 does not work):
   cache: %USERPROFILE%\AppData\Local\Microsoft\Windows\INetCache
   Cookies: C:\Users\UserName\AppData\Local\Microsoft\Windows\INetCookies
   
Registry Setting on Server 2012 R2
0
Manikandan NarayanswamySecurity Specialist & IBM Security GuardiumCommented:
Hi,

Try restarting the Microsoft Exchange Address Book Service. Also please refer the below link where multiple solutions are given to resolve the same

https://support.microsoft.com/en-us/kb/2735060

Thanks
Manikandan
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Manikandan NarayanswamySecurity Specialist & IBM Security GuardiumCommented:
Hi,

One workaround for the same can be to manually point the Windows Server 2012 RDS Server to the Domain Controller by doing the following
HKEY_CURRENT_USER\Software\Microsoft\Exchange\Exchange Provider. Create a String Value with the name DS Server and enter the FQDN of the Global Catalog Server or domain controller

Thanks
Manikandan
0
Rob WilliamsCommented:
Just to confirm; you do have the proper Office licensing?  Typical Office will not run on an RD server, you require Enterprise licensing.  I assume where you say other apps work fine, you have the appropriate license.
0
jackbensonAuthor Commented:
hi, I have an OVS license
thanks
jack
0
jackbensonAuthor Commented:
Manikandan

thanks for the suggestion - I logged into the server via RDP as the Administrator account which does not have a Roaming Profile - and I did as you suggested i.e. created the String Value [DS Server ] of my Domain Server / Global Catalogue in HKEY_CURRENT_USER\Software\Microsoft\Exchange\Exchange Provider

I was then immediately able to open a Outlook and it picked up the email address details from AD - I was very happy :)

then I logged into the same server by RDP as a normal user - created the same Registry Key - then opened outlook - and got this error message:

Cannot Open your Default e-mail folder. Microsoft Exchange is not available. Either there are network problems or the Exchange Server is down for maintenance.

I could in theory go into Mail and delete the outlook profile - but I imagine I would just get problems when I then log into a normal desktop user with that account?

your help is much appreciated
0
jackbensonAuthor Commented:
I finally solved this -

in control panel.. mail.. Email accounts.. (open exchange email account).. More Settings.. Security..
check "Always Prompt For Logon Credentials"

once I did this then I was able to open outlook on Windows Serer 2012 R2

thanks

jack
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jackbensonAuthor Commented:
worked it out myself in the end
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.