Windows 10 don't shows correctly weekdays

Hello. I've recently upgraded from Windows 8.1 to Windows 10 Home. My laptop is a Lenovo IdeaPad Y510p 64bits. The problem is that weekdays don't display correctly. My taskbar shows correctly that today is August 8. If I put the pointer over the date I can see "Saturday, August 8 2015" that is OK. But if I click on the date, the computer shows a monthly calendar where August 8 2015 is Sunday.
Thanks
ConsJMEAAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
the days in US format are shown as
SU MO TU WE TH FR SA
0
JohnBusiness Consultant (Owner)Commented:
It shows fine for me (the monthly format). Click on Date and Time settings lower left and make sure you are in the correct time zone and that daylight savings time is correct. Check all those settings.

Windows 8.1 was correct for me and Windows 10 was correct after upgrade.
0
David Johnson, CD, MVPOwnerCommented:
if you wish you can go into the date/time settings and change the First Day of the Week to Mondaysettings changeopen the calendar in the date part of taskbar and select date and time settings
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

ConsJMEAAuthor Commented:
Thanks to David and John. When I say "the computer shows a monthly calendar where August 8 2015 is Sunday" I'm not referring to the column number but to the column header.
You can see the attached files 1 and 2. Both if the first day is Sunday (spanish "DO") or Monday ("LU") the problem is that August 9 is in the Monday column, but August 9 is Sunday. On the same calendar you can see on the top of the window the weekday correctly displayed. There is a contradiction between the two dates, the one on the top and the one on the table.
I've reviewed another settings and I've realized that a language pack for Spanish Latinamerica was not installed. I've installed it and I've restarted but the problem remains. Then I've changed my display language to English and I've restarted but the problem is still there (you can see file 3).
Thanks
W10Week-1.jpg
W10Week-2.jpg
W10Week-3.jpg
0
JohnBusiness Consultant (Owner)Commented:
There is something wrong with the clock data / application.

Try first SFC and if no, move on to DISM:

System File Checker:

Open cmd.exe with Run as Administrator and run SFC /SCANNOW.
Allow to complete, restart or, preferably, shut down the computer and then start up again.
Test to see if the problem has been corrected.

DISM:

Open cmd.exe with Run as Administrator.
DISM.exe /Online /Cleanup-Image /Scanhealth (takes 15 - 20 minutes).
DISM.exe /Online /Cleanup-Image /Restorehealth (takes 15 - 20 minutes).
Restart the computer and test.
0
JohnBusiness Consultant (Owner)Commented:
Look at this Microsoft Article most of the way down under Calendar and make sure the Calendar key (registry) is not damaged.

http://www.askvg.com/collection-of-windows-10-hidden-secret-registry-tweaks/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ConsJMEAAuthor Commented:
Thanks for your suggestions. SFC and DISM ran without error messages:

***
Microsoft Windows [Version 10.0.10240]
C:\WINDOWS\system32>sfc /scannow
Beginning system scan.  This process will take some time.
Beginning verification phase of system scan.
Verification 100% complete.
Windows Resource Protection did not find any integrity violations.
***
C:\WINDOWS\system32>DISM.exe /Online /Cleanup-Image /Scanhealth
Deployment Image Servicing and Management tool
Version: 10.0.10240.16384
Image Version: 10.0.10240.16384
[==========================100.0%==========================]
No component store corruption detected.
The operation completed successfully.
***

But after restarting the problem was still there. The article about registry tweaks gave to me the solution. The key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\ImmersiveShell had not any DWORD (but the new calendar is enabled). I created a new DWORD UseWin32TrayClockExperience with value 0 according the article. The problem was still there. Then I changed the value to 1 and the old W8 calendar was back with the weekdays correctly displayed. This solution works for me although there is still something wrong in the new calendar that I'm not using.

Like an extra, the article gave to me also the way to disable login screen background image "Hero" that I don't like.
0
JohnBusiness Consultant (Owner)Commented:
@ConsJMEA - Thanks for the update and I was happy to assist.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.