Internet Speed Test show 50% slow

Network DiagramHi,
  I have a strange situation on my network with one SBS2011 Box/DC, several App Servers and 15 workstation desktop PCs.
  I subscribe to Cable Internet Service with speed of 50/5 mbps with multiple static IP addresses.
  When I run Speedtest, I used to get on average 48 / 5 which is reasonable considering all internet traffic goes thru SBS2011 (192.168.1.x network) and CISCO 1811 router.
  Recently I consistently get about 25 / 5 mbps. So download speed has been cut to half of what it used to be. Interestingly enough, upload speed remained the same.
  On the same network, I have a Virtual Machine on VMware box where I have assigned a public IP address (64.233.x.x). When I run speed test from that VM, I get 50/5 mbps consistently. But I get half of that speed on any PC (192.168.1.x) behind Cisco Router.
  Here is what I have done so far in terms of troubleshooting:
 (1)  I took the newest PoE switch (recently installed) out of the network to see if that somehow caused the "leak", but to no avail.
 (2)  I suspected that maybe the CISCO 1811 is acting up and restarted it few times, but to no avail.
 (3)  I replaced CISCO 1811 with a Linksys G Router(assigned 64.233.x.x to it just like CISCO 1811) , but to no avail.
 (4) I disconnected all Ethernet cables from the backup of CISCO 1811 and connected only one desktop PC (to clear any interference or noise that may be originated from any network & computer devices) and ran speed test, but to no avail.
 (5) The only thing that I have NOT tried is assigning a 3rd static/public IP  to Linksys G router, connect it to NetGear swtich  and connect a computer to the Linksys and do a speed test while leaving existing network intact.
  So far what I can conclude is that if there is any device between Cable Modem and Some type of Router (whether it is CISCO or Linksys), I loose half of the internet download speed.

Can you help?
LVL 1
sgleeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
Maybe you have some QoS configured on some device that reserves min 50% of bandwidth for that particular VLAN or that VM?
0
sgleeAuthor Commented:
The only switch that has QoS /VLAN functionality is CISCO PoE that I installed recently. However Like I said in my original posting, I connected a PC directly behind CISCO 1811 after disconnecting entire network from it, the result was the same.
0
JustInCaseCommented:
If traffic shaping is configured on Cisco 1811 or on Netgear gigabit switch it would have no influence if you disconnect entire network.
Check Cisco port speed and duplex on port that is connected to Netgear, and check port on Netgear switch also for the same thing (also check speed and duplex to internal network on Cisco). This should eliminate Cisco router as the root source of problem.

I guess you can backup running and startup Cisco 1811 config and then configure basic configuration without QoS, just basic config 1 VLAN, NAT (if NAT is on Cisco router) and then test internet speed. After test you can return backup of current configuration.

But still, my guess is that network is limited to 25Mb problem is QoS (nice round number), If there is some other problem I guess that there would be some fluctuation in test results even if problem is half duplex, high CPU utilization etc....
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

sgleeAuthor Commented:
Like I mentioned, I have replaced Cisco 1811 with Linksys G router, but to no avail.
0
JustInCaseCommented:
Than only place that is left is your Netgear switch (and cable between Cisco and Netgear).
0
Don JohnstonInstructorCommented:
Configure a PC with one of the public IP addresses and connect it to the Netgear switch.  Then run a speedtest from that PC.
0
sgleeAuthor Commented:
This morning, I bought in DLink Router with Gigabit Ports (on both WAN and 4 LAN ports on the back), assigned a public/static IP address to it , connected my laptop (receiving 192.168.1.x from DLink) to it and ran the speed test. I am using Cat5e cables between NetGear Gigabit Switch and DLink Router and between my laptop and DLink Router.

Eureka! I am getting over 50Mbps.

I am using CAT5e cables everywhere on my network (from PCs to Network Switches except one old PoE switch). However my CISCO 1811 Router has 10/100 ports in the back. Base on the results of my tests, I will need to replace my CISCO 1811 with some kind with Gigabit Ports.
But that does not make a lot of sense because I have had CISCO 1811 for years and I have enjoyed 45-50 Mbps download speed for a couple of years. What changed?

You mentioned "(also check speed and duplex to internal network on Cisco). " - I will call CISCO engineer about that. But there has been no change in the router configuration (in terms of duplex) since they set that up initially. I only make "port forwarding" changes in the router.
0
JustInCaseCommented:
Since Cisco worked for few years without problems, if there is no big change in configuration (VPN, encryption, or long ACL's) or cable quality (damaged or something like that) router should be still OK. Should, not that still is OK.
:)
I would check is duplex correctly configured (full duplex on both sides) on ports between Cisco and Netgear.
And also, I would configure Cisco with basic configuration to check is bandwidth 50/5 or not.
0
sgleeAuthor Commented:
I started working with CISCO engineer to see if there is an issue with the CISCO router. I will keep you posted.
0
sgleeAuthor Commented:
Update:
The CISCO engineer told me that CISCO1811's maximum throughput is 35Mbps. So it was natural that I did not get 50Mbps.
I thought I used to get 50Mbps (after we upgraded the internet speed from 30Mbps to 50Mbps), but I must have been wrong on it.
Now I have to believe that I never performed "Internet Speed Test" since we upgraded to 50Mbps.
I am going to replace CISCO1811 with something with Gigabit ports.

Thanks for your help.
0
Don JohnstonInstructorCommented:
The Cisco engineer is correct that 35mbps is max throughput. But that assumes 64-byte packets.

The 1801-1812 routers can process up to 70,000 packets per second.  With a 64-byte packet, that works out to 35.8mbps (70,000 (packets per second) * 64 (bytes) * 8 (bits per byte)).

But if you were sending 1,500-byte packets, then you would be looking at a (theoretical) 840mbps.

That you said in your original post that you used to see 48mbps but now only see 25mbps shows that you were exceeding that 35mbps number but now you are below that.  You bypassed the Cisco and you were able to see 50mbps so that would indicate the Cisco is the bottleneck.

So it could be you were testing with larger packets before and now are testing with smaller packets.

Is the laptop you used to connect to the gigabit D-Link router the same one you were connecting to the Cisco 1811 when testing?

Have you made any changes to the Cisco router config or upgraded the OS since you were seeing the 48mbps speeds?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sgleeAuthor Commented:
@Don Johnston
Thanks for mathematical theory for CISCO 1811 maximum 35Mbps and you are correct.

 I purchased CISCO1811 in 2005. When we subscribed to Cable Internet Service in 2010, it was at 30Mbps/5Mbps and that is when I think I did most "SpeedTest" and got close to 28-29Mbps.
 In 2014, we upgraded to 50Mbps/5Mbps and I bet that I never performed "SpeedTest" then (until several weeks ago).
 Without having a knowledge about "Maximum Throughput", I assumed that I should get 50Mbps download speed because my CISCOS 1811 has 10/100 Mbps ports.
 But I know better now how to calculate maximum throughput. (... process up to 70,000 packets per second.  With a 64-byte packet, that works out to 35.8mbps (70,000 (packets per second) * 64 (bytes) * 8 (bits per byte). In any router that I will be getting, I will check to see how many packets per second it can process.
0
sgleeAuthor Commented:
Update:
It look a long time, but I finally figured it out.SpeedTestI replaced netgear 5 port gigabit switch with good old 3Com 10/100 switch this morning and it worked like a charm.
Now on my workstation PC behind CISCO 1811 router, I am getting 69 Mbps download speed.
Fyi we are subscribing to 50/5 Internet service.
After all it was not CISCO 1811 10/100 that was slowing down. It was NETGEAR 5 port gigabit switch which is odd, considering it is 10/1000 switch.
0
Don JohnstonInstructorCommented:
If that Netgear 5 port switch isn't a 10/100 switch, it may even be a hub.

10/100/1000 switches tend to have tons of memory to buffer the traffic (1gig coming in to a 10m outbound port needs a lot of space).  And I doubt that a little 5 port switch has much memory.
0
sgleeAuthor Commented:
That may be the case.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.