ActiveSync Doesn't update all the contacts

Hello Guys,

I have an Exchnage environent with many domains and many mailboxes on each domain.
I have a ceratin mailbox that has over 5.6k contacts in it.

When trying to sync it to an  Android phone, It only synced about 4.9k of them, futhermore, after reaching the peak of 4.9k contacts, it starts dropiing.

I tried it on two different phones, on two different Android versions. both Kitkat and Lolipop, and on both the same issues happens.

I also tried the builtin app an several external apps that all showed the same thing. I check the issue on an iPhone and I couldn't reproduce the issue.

Has anyone encountered such an issue?
LVL 8
David SankovskySenior SysAdminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will SzymkowskiSenior Solution ArchitectCommented:
The reason for this is that there is a 5k limit for contacts. which is why it is stopping at 4.9. Aparently there is a registry value that can correct this. See the link below.
http://answers.microsoft.com/en-us/mobiledevices/forum/mdupdate/notes-field-of-contacts-and-sceduled-calendar/7fd60f5c-98bb-46b2-9848-254efe921824

Will.
0
David SankovskySenior SysAdminAuthor Commented:
I'm afraid this refers to Windows Phones, as I stated, the problem is on Android.
0
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
Windows Phone and Android they both use ActiveSync.  As Will stated, the registry fix should resolve the issue.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Will SzymkowskiSenior Solution ArchitectCommented:
This is specifically an ActiveSync issue NOT a phone issue. ActiveSync has a 5k limit.

Will.
0
David SankovskySenior SysAdminAuthor Commented:
Then how do you explain it worked on an iPhone? it still uses the same activesync connector..
0
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
I guess one way to find out is to make the change and see.
0
David SankovskySenior SysAdminAuthor Commented:
I made the change and it still didn't work..
What did work however, was downgrading the Phones to kitkat instead of lollipop.
Seems that the latest patch Samsung deployed to prevent misuse of the SMS security breach somehow caused this problem.
At any rate, it was never a problem with the servers.
Thanks for trying everyone.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
David SankovskySenior SysAdminAuthor Commented:
Problem was with the phones versions. Not with the exchange servers or the activesync as previously suspected.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.