Network Card no longer working in hyper V

Help

since performing windows updates my network card is no longer functioning, I have uninstalled the updates but the problem is still there,

The card is seen but fails to work it has its own IP Address but when performing ipconfig there is no address associated

can someone please help its a server 2012 R2 so there is no way to uninstall and reinstall integration services
pepps11976Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dan CraciunIT ConsultantCommented:
Go to Device Manager, uninstall the network card, reboot.

It will force Windows to re-install the card and reset any network configuration.

HTH,
Dan
pepps11976Author Commented:
Nope I have tried that it is still the same
Dan CraciunIT ConsultantCommented:
OK.
Do you see the card in Control Panel\Network and Internet\Network Connections ?

If so, can you configure it using the GUI (meaning right click on it and click on Properties)?
SolarWinds® Network Configuration Manager (NCM)

SolarWinds® Network Configuration Manager brings structure and peace of mind to configuration management. Bulk config deployment, automatic backups, change detection, vulnerability assessments, and config change templates reduce the time needed for repetitive tasks.

pepps11976Author Commented:
I configure it it appears as an unspecified device if I right click to update it just sits on installing software and does nothing
pepps11976Author Commented:
this has only happened since the windows updates which I have now removed
Dan CraciunIT ConsultantCommented:
OK, so you no longer have the driver installed. I assume in Device Manager it's either under Unknown devices or has an exclamation mark (meaning the driver cannot start).

You can try
- shut down the machine
- from Hyper-V manager, remove all network adapters attached to that VM
- start the VM, let it fully start, then shut it down again
- again, from Hyper-V manager, add a network adapter
- start the VM, check in Device Manager that the card was installed properly
- configure the IP/gateway/netmask, using whatever method you like.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hyper-V

From novice to tech pro — start learning today.