KVM VIRT-MANAGER setup

I have problems with my network settings host / guest on KVM with Centos 6.6 as a host and Ubuntu 14.04 as a guest. Guest OS doesn't show eth0, just l0 interface. So, I believe that there is something wrong with the virtual bridge setup.

I really need help with this.

Regards,

OP
pajkicoPresidentAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
1 of 2 possibilities no network adepter in the vm properties
2 you need the vm additions installed in your client to enable the adapter
pajkicoPresidentAuthor Commented:
There's a network adapter in the vm properties, and I don't see the option to install vm additions. This is a virt-manager view from Centos 6.6.
Manfred BertlManagerCommented:
In KVM (libvirt), you don't need 'vm additions'. Linux should recognize the adapter itself. You may also set the type of adapter in the config for the VM, like 'Intel e1000', which should be recognized by all OSes anyway.

When recognized, you may enter other difficulties in setting up the network... =)

Please post a 'dmesg' from your VM.
pajkicoPresidentAuthor Commented:
Manfred BertlManagerCommented:
As you can see in your screenshots, the e1000 driver is bound to eth0.
You can configure your nc now with 'system-config-network', or create the ifcfg-eth0 file for yourself. It should contain the following parameter:

IPADDR=<your-ip-address>
HWADDR=<your-mac-address>
TYPE=Ethernet
NETMASK=<your-netmask>
BOOTPROTO=none (if not using DHCP)
DEVICE=eth0
DNS1=<your-dns-server>
GATEWAY=<your-default-gateway>

With 'ifup eth0' you can then activate the interface.

edit: sorry, i just forgot, that your guest os is Ubuntu. You will not have a 'system-config-network' there.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.