SQL Server Agent does not start after setting password to sa

Everything worked fine since long ago. MSSQLSERVER and SQLSERVERAGENT services started automatically loged on as Local System
until I set password for sa. Now after setting password for sa SQL Server works normally, but SQLSERVERAGENT does not start.
I get the message
"SQLSERVERAGENT service on Local Computer started and then stopped. Some services stop automatically if they have no work to do, for example, the Performance Logs and Alerts service."
What should be changed to make it work again?

Thr errors from sqlagent.out:
2015-08-11 17:54:31 - ! [298] SQLServer Error: 18456, Login failed for user 'sa'. [SQLSTATE 28000]
2015-08-11 17:54:31 - ! [000] Unable to connect to server '(local)'; SQLServerAgent cannot start
Evgeniy ShakhovskeyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Vitor MontalvãoMSSQL Senior EngineerCommented:
Did you change the SQL Server Agent service account or still Local System?
Guy Hengel [angelIII / a3]Billing EngineerCommented:
I presume likewise that you then also need to change the SQL agent startup settings:
https://msdn.microsoft.com/en-us/library/ms365941.aspx
To change the password used by the SQL Server Agent service

    Click the Start button, point to All Programs, point to Microsoft SQL Server 2016, point to Configuration Tools, and then click SQL Server Configuration Manager.

    In SQL Server Configuration Manager, click SQL Server Services.

    In the details pane, right-click SQL Server Agent (<instancename>), and then click Properties.

    In the SQL Server Agent (<instancename>) Properties dialog box, on the Log On tab, for the account listed in the Account Name box, type the new password in the Password and Confirm Password boxes, and then click OK.

    On a stand-alone instance of SQL Server, the password takes effect immediately, without restarting SQL Server. On a clustered instance, SQL Server might take the SQL Server resource offline, and require a restart.
Evgeniy ShakhovskeyAuthor Commented:
Sorry, I am still working with old 2000 SQL Server.
As for SQL Server Agent service account, it is still Local System
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

Vitor MontalvãoMSSQL Senior EngineerCommented:
Did you delete some logins, like for example BUILTIN\Administrators?
If so, add it back and give it System Administrator role.
Evgeniy ShakhovskeyAuthor Commented:
I did not delete any logins and did not reconfigured anything. I only set password for sa.
Vitor MontalvãoMSSQL Senior EngineerCommented:
Ok. Just want to confirm that.
Do you have any error entry in Event Viewer or SQL Server log?
Evgeniy ShakhovskeyAuthor Commented:
BUILTIN\Administrators is in the list of SQL logins. It has Granted access. It has System Administrators Server Role
Guy Hengel [angelIII / a3]Billing EngineerCommented:
here is the version for SQL 2000 (which is quite similar) on how to set the changed password on the sql agent:
https://technet.microsoft.com/en-us/library/Aa197921%28v=SQL.80%29.aspx
Evgeniy ShakhovskeyAuthor Commented:
Error from Event Viewer/Application:
SQLServerAgent could not be started (reason: Unable to connect to server '(local)'; SQLServerAgent cannot start).

Error from SQLAGENT.OUT file
2015-08-12 17:17:20 - ! [298] SQLServer Error: 18456, Login failed for user 'sa'. [SQLSTATE 28000]
2015-08-12 17:17:20 - ! [000] Unable to connect to server '(local)'; SQLServerAgent cannot start
Anoo S PillaiCommented:
Check SQL Server connection from SQL Server Agent –> Properties.SQLAgent Connection
Evgeniy ShakhovskeyAuthor Commented:
I am not sure where to get SQL Server Agent –> Properties in SQL 2000.
Guy Hengel [angelIII / a3]Billing EngineerCommented:
please see the screenshot from this page, for example:
http://www.quackit.com/sql_server/tutorial/sql_server_agent.cfm
sql-server-agent-1-1-.gifthere you see the context menu, where you would choose "properties"

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Evgeniy ShakhovskeyAuthor Commented:
Thank you for your help! I am ashamed not to find it myself-:( Now it works!
Vitor MontalvãoMSSQL Senior EngineerCommented:
Why didn't you chose Pillai's comment as solution and Guy's as assisted? After all Pillai's the one that bring the solution. Guy just pointed you how to get there.
Evgeniy ShakhovskeyAuthor Commented:
Sorry, it's my fault :-(
Vitor MontalvãoMSSQL Senior EngineerCommented:
If you want I can unaccept the solution for this question so you can split the points.
Guy Hengel [angelIII / a3]Billing EngineerCommented:
Dear Vitor,

  after reviewing the full question history, I think your comment is not "appropriate".

  I had posted (as first) a first info where/how, though ignoring the version, I got the "wrong one".
  then, after some (in my opinion) irrelevant posts, I posted another tech article on how to do it (though that one does not contain a screenshot), and only after the asker indicates that still he could not find the screen (though the screenshot of Pillai is the right one), I posted the last screenshot on how to find it.
 
  so, the points "redistributed" accordingly would be like 75%-25% ...

just my 3c
a3
Vitor MontalvãoMSSQL Senior EngineerCommented:
Many apologizes Guy,

I didn't check the article you sent previously and that makes my comment about points distribuition unecessary. So, maybe the OP also failed to check the article and Pillai's comments sounds to be the solution since it was the OP followed but it was only a reminder.
Anoo S PillaiCommented:
Only eshakhovskey can confirm what was the solution that was applied.

If I did not miss anything, there is a difference between what I was proposing and what Guy was proposing. I mentioned about the settings in tab "Connection" ( marked in Green ) where as the link provided by Guy was mentioning about settings in tab "General" ( marked in Red) in the following pictureSQL Server Agent PropertiesAdding a comment related to the picture that I posted earlier (link ) :- "Beginning with SQL Server 2005, SQL Server Agent does not support SQL Server Authentication. This option is available only when you administer an earlier version of SQL Server."
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.