Windows Server 2008 R2 Firewall logging Issue via GPO

Hello,

I am having trouble turning on the firewall logging via GPO in windows server 2008 R2.  On the Customize Logging Settings for the profile, each time I uncheck the Not Configured Box for the file save location, save the GPO and re-open it, Not configured Box is check again. This is happening with all the profiles. I have attached the screenshot. I have tried multiple times with same issue.
 
Computer Configuration\Polices\Administrative Templates\Windows Settings\Security Settings\Windows Firewall with Advanced Security.

Any help would be highly appreciated.

Thanks
fireall.png
LVL 1
DeoraliAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

btanExec ConsultantCommented:
There are different profile namely

- The Domain Profile is the one that applies when the machine is connected to the corporate network and can contact the domain. Most of the servers do not typically move around the network infrastructure, so most of the time the domain profile is going to apply.

- The Public Profile applies when the computer is connected to a public network

- The Private profile is the exception to Domain profile. It is when the server is not a member of a domain, in which case the Private Profile will apply to it. The settings only take effect when the server is connected to a private network location that isn’t connected to the domain.

In your case, if you are setting the private profile, suggest testing the server if is not joined to domain (unjoin it) but local policy. The setting should persists as set for private network.
0
DeoraliAuthor Commented:
I know how the three different profiles work.  All the workstations and servers are in the windows domain environment.

I have enabled the windows firewall using GPO. For some reasons I am not able to enable firewall logging for dropped packets and successful connections.
0
btanExec ConsultantCommented:
I saw your snapshot is stating Private profile instead of Domain profile hence the mentioned of the 3 profiles. You can view which is "active" on the top node "Windows Firewall with Advanced Security" of the MMC. So do ensure the profile that is active is the one you enabled and configure the firewall logging for.  
You can configure firewall logging by using Group Policy if desired. But what if you want to collect more detailed logging of firewall activity such as kernel mode connections/drops and other filtering activity? You can do this by enabling Windows Filtering Platform (WFP) audit logging as follows:

Auditpol /set /category:"System" /SubCategory:"Filtering Platform Packet Drop" /success:enable /failure:enable

Auditpol /set /category:"System" /SubCategory:"Filtering Platform Connection" /success:enable /failure:enable

Note that this form of logging may be very verbose, so be careful when enabling this on a computer in your production environment.
http://www.windowsnetworking.com/kbase/WindowsTips/Windows7/AdminTips/Security/EnablingWindowsFirewallauditlogging.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.