BPA Scan Has Failed

Hi

we have an SBS 2008 R" server and whenever we try to run the BPA we get the error "The Best Practices Analyzer scan has failed. The directory name is invalid".

Googled it but coming up empty for this exact error.

Any help would be appreciated.
dilesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cris HannaCommented:
Have you tried uninstalling and reinstalling?
0
dilesAuthor Commented:
Apologies, I made a mistake in my original post. This is Server 2008 R2 and not SBS.

I have looked but I can't see of a way to uninstall\reinstall. The BPA is integrated in to the MMC.
0
pgm554Commented:
Did you download the bpa or was this something that was always there in the mmc?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

dilesAuthor Commented:
It's integrated within the MMC, its in the Server Manager Roles/Features.
0
pgm554Commented:
Download the standalone and see if you can run it that way.
0
dilesAuthor Commented:
The BPA in the MMC is for all the different services which is more than the standalone one does. I will try it but cannot see it will fix the MMC version, the MMC is the most useful option.

Thanks and I will report back.
0
pgm554Commented:
0
dilesAuthor Commented:
No I had not, although on this server we have not made changes to the way scripts are executed I will configure a GPO to do this - Just in case.

Thanks for this

Dave
0
dilesAuthor Commented:
Just checked and the GPO is set correctly.

Thanks anyway.
0
dilesAuthor Commented:
Please close this question
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dilesAuthor Commented:
no solution found
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.