.NET4 on II6 Results in "File Not Found"

I have an old Webserver that I just inherited full of Cold Fusion code. I need this server to run a .NET4 Web application on it, so I created a new site in IIS6 on its own AppPool. I also had to install .NET4 because .NET2 was the only .NET version installed on the server.

Anyway, when I run the site as .NET2 I get an error, but at least it compiles. As soon as I switch it to .NET4, I get a "404: Page Not Found" error. Which, obviously, is not true; the Default.aspx page is there (and yes, the default document is set to Default.aspx).

I've read this page to no avail. The three solutions suggest to put the site in a different app pool (which i did); disable the ASP.NET 4.0 extensionless feature in the registry (which doesn't exist in the registry), or Re-Create the script mappings for ASP.NET v4.0.

I did not do the last step because I'm not sure what that means.

Anyway, I'm not sure if the article i've been reading is where I even should be looking.

Does anyone have any ideas?

Thanks!

EDIT: Someone suggested adding the "EnableExtensionlessUrls" to the Registry and setting its value to "0", and then rebooting IIS. I did that. Nothing's changed.
infotechelgAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

infotechelgAuthor Commented:
Figured it out. In IIS6 under "Web Service Extensions", "ASP.NET v4.0xxx" was set to "Prohibited". Not sure why, but it was. Now it works.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
David Johnson, CD, MVPOwnerCommented:
did you install the coldfusion server items.  IIS6 tends to imply to me that you are running this on server 2003 which support ended on July 14th.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.