File share over domain trust

Domain A (server 2012 R2) is set up with a one way trust to Domain B (server 2008 R2).  I have a shared folder on Domain A that users from Domain B need to access.  I have added a test user from domain B to the share permissions and the folder ntfs security permissions on Domain A.  Anytime I try to access the share from Domain b I get the error: you do not have permission to access \\machine.xyz.local\fileshare.

Conditional forwarders are set up for each domain.  I also tried to set up a two way trust and I'm getting the same problem.
LVL 1
jasp101Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Toni UranjekConsultant/TrainerCommented:
What kind of trust did you create?
Are DomainA and DomainB actually in separate forests?
0
jasp101Author Commented:
Yes.
0
jasp101Author Commented:
Different forests.  It is a one-way external trust.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Toni UranjekConsultant/TrainerCommented:
What are Domain Functional Levels?
What are Forest Functional Levels?
Did you create External trust, which supports only NTLM authentication or Forest trust, which support NTLM and Kerberos authentication?
0
Toni UranjekConsultant/TrainerCommented:
I've seen your answer regarding type of trust .

Did you try to create one way forest trust?
Both forests should be at Forest Functional Level 2003.
0
jasp101Author Commented:
Both domains are forest level 2008 R2.  I removed the one way external trust and set up a two way forest trust and I am still having the same issue.  I have a user group set up on domain b and added that group to both the share permissions and the ntfs permissions on the share in domain a.
0
Toni UranjekConsultant/TrainerCommented:
Did you check system time in both forests?
Are these forests on same network?
Do you have working Global Catalog for each forest?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jasp101Author Commented:
i was trying to connect with the same username in both domains.  after trying a different username it worked.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.