accessing a folder for listing the data

Hi, I have an address like this:

//192.168.2.99/folder1/folder2

i need to browse this folder from coldfusion, i have username/password with me to send accross to browse this folder,

i am using cfftp for this purpose using the passiv="yes". but it gives me an error:

An error occurred while establishing an FTP connection.

i am out of ideas, is there any other way of fixing it

Thanks
LVL 16
Gurpreet Singh RandhawaCEOAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ryan ChongCommented:
Are you manage to connect to path: //192.168.2.99/folder1/folder2 via a FTP client?

You may setup the same configuration in your CFFTP tag, like:

<cfftp
	action="listDir"
	name="RemoteDirectoryContents"
	directory="yourDirectory"
	server="localhost"
	username="userid"
	password="password">

Open in new window

for more info:

ColdFusion FTP (cfftp)
http://www.quackit.com/coldfusion/tutorial/coldfusion_ftp.cfm
0
Gurpreet Singh RandhawaCEOAuthor Commented:
via ftp, it is not getting connected..

So i think something else needs to be done, but what i am not sure
0
Ryan ChongCommented:
so, is your purpose is to list down a directory at your server end?
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Gurpreet Singh RandhawaCEOAuthor Commented:
yes, from webpage i should be able to go into that directory adn list its contents

i tried with cfdirectory but that just shows empty dump, nothing in it, it does not username/password so i am bit lost where i can fix it
0
Ryan ChongCommented:
so:

1. is this a network path that the web server trying to access?

//192.168.2.99/folder1/folder2

2. if at the server machine, can we directly access to that folder by opening a new window folder?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Gurpreet Singh RandhawaCEOAuthor Commented:
i solved it, basically i mapped a directory which came as z:\, the permissions were missing and firewal was an issue, modified that and access the drive using the batch file by providing the username/password and it worked, Thanks for the help.

i am accepting your answer at least you tried to help me out in this.

A motivation is a big factor


regards
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ColdFusion Language

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.