Why is my Microsoft Remote Desktop not working after Windows 10 upgrade?

I use the app Microsoft Remote Desktop (MRD) on my macbook pro with latest OS.  I would connect to my Windows 7 computer with this app.  After I upgraded to Windows 10 I cannot connect with the MRD app.  I checked the IP address of the Windows 10 computer and it's the same IP.  The login and password has not changed.

I also use Google Chrome Remote desktop sometimes and am able to connect to the Windows 10 computer.

Why is this happening?  How can I get MRD working again?

fyi I did turn off a lot of that privacy crap on my own as described here.  I did not install that application though.
LVL 18
Kyle SantosCustomer RelationsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Make sure File and Print and Network Discovery are both ON (Network Settings)

Make sure in System Properties (My Computer, Properties, Advanced System Settings), Remote Tab that both Allow Remote Assistance and Allow Remote Connections are both enabled. Two settings. Default is OFF.

Please let us know.
0
David Johnson, CD, MVPOwnerCommented:
while you're in control panel/system ensure that it is windows 10 pro not just windows 10
0
Thomas GrassiSystems AdministratorCommented:
Also check windows firewall for Remote Desktop on inbound rules enable them if not enabled
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Kyle SantosCustomer RelationsAuthor Commented:
@john
All of those are already on.

@ David
It is Windows 10 Pro.
0
Kyle SantosCustomer RelationsAuthor Commented:
@Thomas
Remote Desktop is already enabled.

It appears all my original settings that were set up in Windows 7 transferred over unaffected with the Windows 10 upgrade.  That's nice to know. :)
0
JohnBusiness Consultant (Owner)Commented:
It appears all my original settings that were set up in Windows 7 transferred over

Make sure of the following (all things I had to do after upgrading):

Update all your drivers including BIOS, Chipset, Video and wired, wireless Network Cards.
Repair or reinstall your Antivirus application. Upgrade to the newest version if it is not already newest.
Run TCP/IP Reset.

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
Then restart the computer

Please let us know.
0
rindiCommented:
In the Remote settings of your Windows 10 PC make sure the allow remote connections is on, and that the option below that calling for "Network level authentication" is off (that can cause issues with older Remote Desktop Clients), and also make sure the user account you will be using is in the allowed user's list.
0
David Johnson, CD, MVPOwnerCommented:
I have no problem connecting from Windows 7 Ent/10Pro to Windows 10 Pro With or without network level authentication
0
rindiCommented:
He's connecting from MAC OSX (or at least it's a MAC he's connecting from). It's Remote Desktop Connection utility probably can't authenticate if the host uses the wrong authentication level.
0
strungCommented:
What version of the Microsoft RDP client are you using? The latest version for OS X is ver. 8.0.18.

See:  https://itunes.apple.com/ca/app/microsoft-remote-desktop/id715768417?mt=12

 If yours is older than that, you should update it.
0
Kyle SantosCustomer RelationsAuthor Commented:
Thank you for the additional suggestions.  I will check them out shortly!
0
Kyle SantosCustomer RelationsAuthor Commented:
Version 8.0.18
Hmm, I checked my version and its up to date.
0
Kyle SantosCustomer RelationsAuthor Commented:
Ok, I turned off the DHCP and NAT mode on my router and set to Bridge mode.  This way the Windows 10 PC got a different IP and I was able to connect with Microsoft Remote Desktop on my LAN.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.