Email address format to external recipients

Hi,

I hope someone can help with what I thought would be a simple issue. To give a little background, we have a hybrid environment - Exchange 2010 / Exchange 2013 / Exchange Online. At the moment, there are only test mailboxes on Exchange Online. When an email is sent out from an on-premises mailbox to an external recipient, it looks like the below showing the full email address with the domain name.

on-premise
If I send an email out from an Exchange Online mailbox to an external recipient however, it only shows the display name (in this case Office365 Test) and not the full email address.

Online
How can I set this so that on-premises mailboxes also just show the display name as Exchange Online does?

SimpleDisplayName is not enabled for any domain and is not even populated for the Exchange Online account.

Thanks in advance.
AlAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AmitIT ArchitectCommented:
This is outlook end setting. Read this:
http://www.howto-outlook.com/howto/viewsenderaddress.htm
0
AlAuthor Commented:
Hi,

Thanks for the comment but I don't think that's the solution. Also, what I'm trying to achieve is the opposite of what that article describes. Additionally, this happens when mail is received by OWA, GMail, any external client/service; not just Outlook. It shows the full email address, not the display name. An email sent from Exchange Online shows only this display name which is how I want it to be set. There's nothing at all that can be done server-side to achieve that?
0
AlAuthor Commented:
Any other suggestions anyone? Technet isn't proving too useful either...
0
AlAuthor Commented:
Fixed it myself. In Exchange 2010, under Hub Transport > Remote domains > Message Format tab, ensure "Display sender's name on messages" is checked.

display name.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AlAuthor Commented:
Found solution through my own investigation.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.