Multi-Parameter Report SQL 2008

I am trying to build a report using SQL Server Business Intelligence Development Studio 2008. I am successful with building my Datasource, Dataset, and linking 3 tables for the fields I want to report on. One of my fields is named build type and the data within can be either New, Rebuild, or Vendor Build. I have gone through the steps for creating parameters and successfully get the drop downs when previewing reports, but no matter what I choose ALL data is returned in the report.... I am not sure what I am missing.. I have followed every tutorial to the letter and keep getting the same result. Once I get this done I will also need to created a date range parameter, but for now I would be happy with just choosing of filtering by Build Type.
LVL 1
DKHeneryAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

edtechdbaCommented:
Is your SQL embedded in your report?
Or are you calling a stored procedure?

It sounds like you need to add criteria into your SQL (embedded or db stored procedure) to filter on only the specific build type.

Ex.
select col1, col2, col3
from table
where col1 = @buildtype_parameter (your parameter name)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DKHeneryAuthor Commented:
Thanks for the input... it got me inn the right direction and I have solved that issue... next I have another field/column called System_Model with data of either "Virtual" or the specific hardware model of the computer. I successfully built a Parameter with the Value of Virtual and it returns only Virtual machines in the table.. how do I setup a second value that would return everything that is NOT Virtual?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DB Reporting Tools

From novice to tech pro — start learning today.