install framework 4.5

Can I install framework 4.5 without updating 4.0?  I want both exist on my server.
VBdotnet2005Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Russ SuterCommented:
Why? Framework 4.5 is fully backward compatible with 4.0.
0
Dave BaldwinFixer of ProblemsCommented:
From http://www.microsoft.com/en-us/download/details.aspx?id=42642 
This version of the .NET Framework runs side-by-side with the .NET Framework 3.5 SP1 and earlier versions, but performs an in-place update for the .NET Framework 4, .NET Framework 4.5 and .NET Framework 4.5.1.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JohnBusiness Consultant (Owner)Commented:
You should be able to click in Windows Features (Programs and Features) to install .NET Framework 4.5. I am not sure (depending on the server if you may first need to install Windows Experience. I don't think so.
0
MisbahCommented:
answer is no ,
 .NET 4 and 4.5 share the same base
.NET 3.5 and 2 share the same base
so you only can have these two bases running side by side.
0
Jacques Bourgeois (James Burger)PresidentCommented:
You can't, and anyway, there is absolutely no reason to do that. Applications compiled for 4.0 will run exactly the same way in 4.5.

4.5 simply brings updates, new classes and new possibilities in the framework. Asking to have both is like asking if you can have Visual Studio 2013 and Visual Studio Update 1 on the same computer.

If this is because you need to code for 4.0, you can do it even if 4.5 is the one installed on the development computer. Simply to into the project's Properties window and set 4.0 as the target framework. Visual Studio will automatically hide the newer features when you work in that project, and it will mark it for 4.0 when you will compile it. The application will thus be recognized as a 4.0 application and will be able to run on any computer that has framework 4.0 or more installed.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.