iPhone 6 - no internet

In a remote location, my iPhone 6 cannot access the internet, says "safari could not connect with the server" regardless with what site you pick (e.g., CNN, ESPN, etc.).

My wife's iPhone 6 connected fine at the same place.

I checked settings on her's & mine, I could see no difference.

At home I'm connected by my WiFi, so it's fine.

What's the trick?

Thanks
Richard KortsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Go to Settings and turn Airplane Mode ON.  Wait 15 seconds and then turn it OFF. This does the equivalent of a DNS Flush and can often makes the cellular connection work better. I use this method fairly frequently.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TemodyPickalbatros, IT ManagerCommented:
also try to forget that WIFI network and connect to it again
1
Richard KortsAuthor Commented:
To Temody

What does "also try to forget that WIFI network and connect to it again" mean?
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

TemodyPickalbatros, IT ManagerCommented:
Open the Settings app and head to “Wi-Fi” settings as usual
Look for the wi-fi router / network name that you want to forget, then tap on the (i) info button
Tap “Forget this Network” then confirm to drop the network from the list by tapping on “Forget”
Then connect to that wifi again
1
Richard KortsAuthor Commented:
I have not yet been in a situation where this is applicable; I will take the steps you all recommend, try it & let you know.

Thanks
0
JohnBusiness Consultant (Owner)Commented:
Thanks for the update and I was happy to help
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
iPhone

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.