Exchange server

Hello EE,

Please help out with this issue.

Mail are not dropping from inside or outside the network.

I tried to open Exchange Management console but can't open it instead some random initialization failed error messages would popped up,e.g kerberos authentication failed, WINRM couldn't complete the operation.

I checked the event logs and I found error relating to Microsoft Exchange active directory topology service, and I tried to restart the service but the service can't be stopped and all other services control by miscrosoft exchange active directory topology,as they are all stopped, can't be started.

Please note that I have deleted nodestructuresetting in registry editor, this didn't resolve the problem.

Thanks
HafeezAzeezAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zacharia KurianAdministrator- Data Center & NetworkCommented:
Needs more details about your exchange, like version with RU /CU, OS and if it is physical server or virtualized. Microsoft Exchange active directory topology service has many dependencies and it is hard to pin point the exact cause.

If you can post the event log erros

Check if your PDC/DCs are working fine and the time is correct on all your member servers including your exchange server. Check if your AD is working fine. You could check the following;

1. See if any 3rd party software causing issues.
2. Check if any misconfigured  GPOS applied to the server.
3. If it is a physical server, check it doesn't has any hard ware issues.
4. Check the network settings are correct.
5. If it is virtualized with VMware see if you have installed the VMware tools and it is using the  latest driver for network.

Zac.
0
HafeezAzeezAuthor Commented:
Thanks Zac,

The exchange is 2010 standard with the latest ru 10.xx

The exchange is on a physical machine that we use as domain controller.

The AD is not working as I tried to open ADDS it but gave error message:
'Data from the active directory users and computers (xxxx.xxxx.local ) is not available from the domain controller (xxxx.xxxx.local) because: the server is not operational. Try again later, or choose another DC by selecting connect to domain controller on the context menu.'
'The directory schema is not accessible because:
An invalid directory pathname was passed. For this reason the new menu may be inaccurate,and extension snap-ins may not work properly.

All services that depends on microsoft Exchange Active directory topology such as;
Ms exchange transport
Exchange throttling
Exchange mailbox assistants etc
Are stopped and can't be started.

Sorry I am unable to post the event log error

Thanks
0
Zacharia KurianAdministrator- Data Center & NetworkCommented:
The exchange is on a physical machine that we use as domain controller

We use such kind of setup only in labs for testing purpose.

Do you have another DC or this is the only one? If you have another working DC (additional domain), promote it as your PDC, demote the existing PDC, make it as member server and try fixing your exchange.

If you do not have another working DC, then the option is to rebuild it if you have a good latest backup for this server (PDC & Exchange).

It is very hard to guide you to find the cause and solve it since you have everything in one box.

Can you try get a professional local support?

Zac
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

HafeezAzeezAuthor Commented:
Hello Zac,

Thank you

I cannot get a local professional support.

however, I wouldnt mind if you can guide me through on how to find the cause and solve this problem.

EE is all help I have please.

Thanks
0
Miguel Angel Perez MuñozCommented:
You can try running DCDIAG and paste output: https://technet.microsoft.com/en-us/library/cc776854(v=ws.10).aspx
0
HafeezAzeezAuthor Commented:
Thank you, the problem was cause by bad HDD.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.