Remote desktop does not work with windows 10 upgraded computers

We have a single 2011 small business server, which is working fine. We use remote desktop both from outside the building and locally also.

All are working fine, apart from a couple of workstations we have just upgraded to windows 10 pro.

I cannot connect to either pc, internally or externally using remote desktop or OWA.

All of the settings seem to have come across OK from the Windows 7 config that we had in place, We can connect to OWA to check e-mail, but the remote connection option, displays the correct computer, but says it cannot find it when we try to connect.

I have tried using remote desktop locally with both the pc name and local IP address, and it still fails

I can see that many other people have had exactly the same problem, but I can find no fix for this.

Can anyone help, as we are desperate to be able to provide remote access for the couple of workers who access the computers we have upgraded to windows 10.

Any help would be very much appreciated.

Thanks
LVL 1
nigelbeatsonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
If you are on SBS 2011 then you need to instruct users to turn on compatibility mode in IE11 *and* add RWA to the "trusted sites" zone. BOTH of these steps are required for RWA to work on windows 10 (and 8.1 and 8.0.)
Michael ChisholmCommented:
1. Make sure your server is configured to accept remote access from clients with Network authentication.

2. It wouldn't hurt to check the firewall also as it may have been turned on during the upgrade. If you have it on turn it off for testing.

3. Test an RDP connection to a windows 7 system from a windows 10 system and make sure it is not only a windows 10 problem.  

4.  Post results
nigelbeatsonAuthor Commented:
This was FULLY working before we installed the windows 10 upgrade to 2 of our workstations. The rest still running on windows V7 pro, still work perfectly.

I have change site https://remote.comainname.co.uk to compatibility mode, and I have also added the url for the site to the internet  op[tions > security > trusted sites

I have tested it, but it still produces the following error >

screenshot of error
Amazon Web Services

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

nigelbeatsonAuthor Commented:
I presume the above changes should be made to the client initiating the remote connection, and not the computer we are trying to remote into?
nigelbeatsonAuthor Commented:
do you mean on the client side?

I know how to add trusted sites to internet explorer, but how do we add rwa? I usually add a url

many thanks
nigelbeatsonAuthor Commented:
I can confirm that locally I can connect from a windows 10 computer to a windows 7 computer, but not from a windows 7 or 10 computer to a windows 10 PC.

windows 10 does not allow a remote connection either locally or externally using owa

many thanks
Cliff GaliherCommented:
Based on your screenshot, the site is not in compatibility mode. That is easily identifiable in the title bar by a "torn page" icon. As I said, *both* must be done for RWA to work.  And yes, it working perfectly in Win7 is completely normal. This is a result of RWA being written for older browsers, and when win8 (and newer) shipped, the new browser doesn't like the older site, hence the need for compat mode.

-Cliff
nigelbeatsonAuthor Commented:
I am sure you are right about this, but when I select the compatibility view settings to include the site remote.domainname.co.uk it just adds domainname.co.uk to the list, and no torn page appears in the address bar.

what am I missing?
nigelbeatsonAuthor Commented:
I seem to think that the compatibility mode torn page icon is not now displayed in IE11?? I can see our domain name is in the compatibility mode list, and the https://remote.domainname.co.uk is also in the trusted sites list, but It still produces the same error.

Any other ideas?

Thanks for your help.
David AtkinTechnical DirectorCommented:
Can you check on the client machines firewall to make sure that 'Remote Desktop- user mode (TCP-In)' and 'Remote Desktop- user mode (UDP-In) are allowed in the inbound rules.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nigelbeatsonAuthor Commented:
that was it! many thanks. not sure why this setting in particular would not be taken from windows v7 during the upgrade, but we are all working now.

many thanks to all.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.