Link to home
Start Free TrialLog in
Avatar of BrianK007
BrianK007Flag for United States of America

asked on

Windows 10 Mail native app stops working after Win 10 upgrade

With Windows 8.1 I used the native Mail app to connect to my company's Exchange server. The setup information required was exactly that of what an Android or iPhone would use. Basically you just needed your OWA URL, your domain, username and password. Simple as that, and you could then sync up with your Exchange account from non-member PC's for email and calendar, same as in OWA, except cached.

I, along with a handful of our other users, have upgraded our personal machines to Windows 10, and the native mail app refuses to talk to Exchange. The same settings are required to set it up. There does not appear to be anything new to the app that would cause Exchange to turn its nose up, but whenever you try to sync up it gives an error:

Something went wrong...
We can't connect to mail.our OWAaddress.com right now.
Make sure you have a connection, then try again.
Error Code: 0x80072ee2

Do I need to change something on our Exchange server to allow this to work properly? Anyone experienced this as well?
Avatar of John
John
Flag of Canada image

I use Outlook 2013 and all that worked fine in my upgrade from Windows 8.1 to Windows 10. I assume you are using Windows 10 Pro.

Open the Mail app and re-enter your settings to see if that works.
ASKER CERTIFIED SOLUTION
Avatar of David Johnson, CD
David Johnson, CD
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of BrianK007

ASKER

There seems to be some problem with the mal app if you had the insider preview installed. I have done fresh upgrades post-release, and the mail app does seem to work for some reason or another. I have uninstalled and reinstalled the mail app as well as blown away all of the cached settings in between, but still no dice. Still unsolved, but I have chalked it up to some weird insider preview residue since it does seem to work on new upgrades. Initially I thought it was the way the app interacted with our Exchange server, but that suspicion has been laid to rest.