Increase attachment size Exchange 2013

I'm trying to increase the the quota for outbound attachments to 30MB for certain users. I need help figuring this out.
gustavomor02Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Amit KumarCommented:
On user properties you can increase size limit for specific user but if your Exchange send connector does not allow and gateway ahead of your Exchange does not allow such capacity then you won't be able to send e-mail.

and one more thing Send Connector and gateway always configured org. level.

You can do one thing configure your exchange org. to send mail upto 30 MB and then configure a transport rule that if mail is going outside for all users more than like 20 MB then it send NDR saying mail size has been exceeded, but except one DL. Add specific user to that Group.
0
Adam BrownSr Solutions ArchitectCommented:
There are two places you'll have to do this. First, you have to increase the quota that is set on the Transport service, this is the organizational limit and cannot be set lower than the highest user-based quota. This is done by going to Mail flow>send connectors in the Exchange Admin Center, modifying the Internet send connector (or any send connector you have that is enabled), then changing the Maximum Send Message Size value. You'll do the same with any Receive connectors you have. That's done the same way, but using the Receive Connectors tab.

The other limit is the per-user limit. You do this by modifying the users that need to have a limit that is *lower* than the transport settings (the limits you set on the send and receive connectors). You can do this in EAC by going to recipients, doubleclicking the user you want to change, then go to Mailbox features, then scroll down to message size restrictions. You'll set the limits there.

If you don't yet have settings for any of your users, figure out what your default limits will be, then run the following cmdlet in the Exchange Management Shell (Powershell):

get-mailbox | set-mailbox -maxsendsize <enter the maximum size people can send, using kb,mb,gb after the value> -maxreceivesize <same as for maxsendsize>

That will make all mailboxes follow whatever is lowest, the send/receive connector limits or their mailbox setting. Once that's done, you can go into the users you want to have a bigger limit and change them individually. If there are a lot of users to change, create a .csv file with the word "user" on the first line (no quotes), save it to a memorable location, then run this:

$users = import-csv <file path and name>
foreach ($user in $users)
{set-mailbox $user.user -maxsendsize <size limit as above> -maxreceivesize <same>}

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.