Procurve Switch

I'm not too conversant with switch vlan configurations, but here goes. A business has 3 switches in the only cab as follows:-

Procurve 2626     192.168.0.10 - Static IP

Procurve 2626     192.168.0.11 - Static IP

Procurve 2610-24/12PWR      192.168.0.47   (Yes that's correct .47) - Default VLAN DHCP/Bootp


Not sure who set this up but either way, the problematic switch seems to be the Procurve 2610-24/12PWR 192.168.0.47

The network was running slow several months ago and I noticed the Procurve 2610-24/12PWR had a conflicting ip address with a workstation. I rebooted the switches and the Procurve 2610-24/12PWR picked up an ip address of 192.168.0.30. For quickness I justed added this to the DHCP reservations to keep the business up and running at the time so that no other equipment picked up that address, as .30 is normally assigned to workstations ! It seemed to solve the issue for several months.

However, recently the network has been running slow again. Had to reboot and the switch is now on IP  192.168.0.47 which doesn't conflict. Someone set it up with an IP Configuration as "Default VLAN DHCP/Bootp". Even changing the setting to a "Manual" IP Address doesn't appear to rectify the issue. At the moment all is working, but it's sure to mess up again.

I'm assuming the issue is with the vlan configuration or DHCP issues. It's not essential that the business has a vlan now as apparently the domain has since been rebuilt since the switches were first installed. Looking at the DHCP on the server the 192.168.0.47 address is showing as inactive.


Thanks.
LVL 1
discoveranotherAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
Why don't you create separate VLAN for management on those switches, add VLAN interface on each switch and add that VLAN to trunks? Since switch IP address will be in separate VLAN, with separate address range in will never conflict with any of your hosts. You should also add default- gateway to those switches if you want to be able to configure them from another VLAN.
That would be better way.

Another way would be to add static IP addresses to those switches, let's say
192.168.0.251
192.168.0.252
192.168.0.253
and remove those IP addresses from DHCP address range so you DHCP assigns IP addresses in range 192.168.0.5 - 192.168.0.250.
And whatever you do - save changes before you exit. :)
1
Mick FinleyNetwork EngineerCommented:
I'm confused.  Why don't you just add a static ip address to the 2610?  VLANs would be the way to go, but it'd work either way
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
discoveranotherAuthor Commented:
Thanks for the responses.

Fair point about the static ip's. Basically, something I omitted in error. I did add a static IP of .12 following on from the other ip's to the Procurve 2610-24/12PWR , however, strangely, the problem still occurred with the slow network even after adding a static ip, this is what has prompted me to try another switch possibly in place of the Procurve 2610-24/12PWR .

By the way, I couldn't see anywhere to reboot the Procurve 2610-24/12PWR  remotely.
0
Hey MSSPs! What's your total cost of ownership?

WEBINAR: Managed security service providers often deploy & manage products from a variety of solution vendors. But is this really the best approach when it comes to saving time AND money? Join us on Aug. 15th to learn how you can improve your total cost of ownership today!

JustInCaseCommented:
Command from CLI to reload switchis is reload.
0
Mick FinleyNetwork EngineerCommented:
when setting the static ip, did you run command "no dhcp"  also?  Also, as far as network slow, I assume you are aware the 2610 is a 10/100 switch, not gig.
0
discoveranotherAuthor Commented:
I'm logging into the switched via a web browser. Good point about the 2610 being a 10\100, all the more reason to swap it out.
0
discoveranotherAuthor Commented:
No answers useful
0
Mick FinleyNetwork EngineerCommented:
VLAN 1 is the default and is on all procurve switches, the "Default VLAN DHCP/Bootp" can be changed typing the following:
config t
vlan 1
no dhcp
ip address <whatever you want the ip address to be/subnet mask>
untag 1-24 <all ports available>
exit
ip default-gateway <you network gateway here>
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.