RRAS "Routing and Remote Access service" won't run

SBS 2008 server having an issue with RRAS. We migrated an existing SBS 2008 to new hardware using Double Take by Vision Solutions.  When the new server booted, remote connections are not working and RRAS won't run.  A tech helped me find this fix, but the problem I am having is at step 13 through 16, I cannot get the .inf file to overwrite itself:

http://iswwwup.com/t/c679dfc487c8/rras-won-rsquo-t-start-with-8007042a-or-event-id-7024-aka-the-ldquo-ro.html

What should I do to make that overwrite? At step 13 I opened the nettcpip.inf file and made the edit, but it won't allow me to save. It keeps saying "check the path and file name".
wfcrrAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

smckeown777Commented:
I assume you are using Notepad to make this edit?
Save the file to your Desktop
Once saved then copy it to the original folder and that should bypass the error
wfcrrAuthor Commented:
Ok, tried that and when I moved the new file to that folder got a "Destination Folder Access Denied" message that stated You need permission to perform this action.
smckeown777Commented:
No clue why you are getting that error, I can access and change files in that folder on my end fine...

Reboot the server in safe mode and copy the file in and it should allow access...that would be my next step to try
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

wfcrrAuthor Commented:
Hmm.  Booted in Safe Mode with Networking and it did the same thing "Destination Folder Access Denied" message that stated You need permission to perform this action. I am dragging and dropping the new file from the Desktop to the inf folder. Also tried opening the file and making the change and when I save, gives the same "denied" message.  Do you think it would be different if I log onto the Local administrator and try it?
smckeown777Commented:
Are u not logging in as a domain admin?
This is a DC there should be no local admin

Have u ran the Fix My Network  wizard since u had this issue? That's the first thing to run on a SBS box when issues...
wfcrrAuthor Commented:
logged on as domain administrator.  Is there another way to run Fix my Network? I am trying to get to it from SBS Console, but the Console is having a problem and I can't get to Network tab to click on Connectivity
wfcrrAuthor Commented:
Let's pick up on this one tomorrow.  Thanks for the help on it so far!
smckeown777Commented:
Yes - path to the FixMyNetwork exe is - C:\Program Files\Windows Small Business Server\Bin\FNCW.exe

Right click on that and select Run as Admin - then see what it finds wrong, you might need to fix the items it finds one by one but that's the first thing you need to run when having issues on the SBS machines...
Dirk MareSystems Engineer (Acting IT Manager)Commented:
Take ownership of the inf folder (%winroot%\inf) after that you should be able edit/overwrite the existing inf file..

DirkMare
wfcrrAuthor Commented:
@smckeown777, launched FNCW.exe and then went to Connect to the Internet Wizard and ran that, but it stopped working. Twice.  Next I tried to just run the Fix my Network Wizard and same thing, it stopped working.  What should I look at now? Would deleting these registry keys affect the Fix it wizard?  
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock
◦HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2


@Dirk Mare, I went to the nettcpip.inf file, right clicked, properties, security tab, selected Administrators/Contuso/Administrators and chose Advanced tab, Permissions, Edit, Permissions, Edit, then selected all tick boxes Allow Full Control through Take Ownership , but as I saved it said "Access Denied.
Dirk MareSystems Engineer (Acting IT Manager)Commented:
Not at file level but at folder level..

DirkMare
wfcrrAuthor Commented:
Ok, tried that  and said Access Denied. I right clicked inf folder, properties, Security tab, selected Administrators/Contuso/Adminstrators, Advanced button, Permissions tab, Adminstrators/Contuso/Administrators, Edit, Permissions, selected Adminstrators/Contuso/Administrators, Edit, selected Full Control through Take Ownership and as I saved each window, said Access Denied.

I am logged on the network administrator logon "contuso/administrator" account. Should that be able to take ownership?  

The error window is "Error Applying Securty" and the message is An error occurred while applying security information to: C;\Windows\inf  Access is denied.
Dirk MareSystems Engineer (Acting IT Manager)Commented:
To take ownership of a file or folder
Open Windows Explorer, and then locate the file or folder you want to take ownership of.
Right-click the file or folder, click Properties, and then click the Security tab.
Click Advanced, and then click the Owner tab.
Click Edit, and then do one of the following:
To change the owner to a user or group that is not listed, click Other users and groups and, in Enter the object name to select (examples), type the name of the user or group, and then click OK.

To change the owner to a user or group that is listed, in the Change owner to box, click the new owner.

(Optional) To change the owner of all subcontainers and objects within the tree, select the Replace owner on subcontainers and objects check box.

DirkMare
wfcrrAuthor Commented:
Ok, was able to select in the change owner box "Administrator\CONTUSO\Administrator" and save that change.  However, when I try to edit the nettcpip.inf file, it won't save, still says "Notepad-Cannot create the C:\Windows\inf\nettcpip.inf file.  Make sure that the path and file name are correct.

I also tried saving to Desktop and then drag n drop the newly saved file into the inf folder, but said Destination Folder access denied, you need to permission to do this.
Dirk MareSystems Engineer (Acting IT Manager)Commented:
Okay try to edit the file from normal safe mode and not with Networking..

DirkMare
wfcrrAuthor Commented:
booted in Safe Mode only, not with Networking, same result. Went to permissions on inf folder, Security tab, Advanced, Owner tab, edit, chose the Change owner as Administrator\CONTUSO\Administrator, and when I tried to then go edit the file, access denied.  I also tried drag and drop the newly saved file from Desktop to the inf folder, and access denied.

Is it possible to boot with installation DVD and remove that file and then reinstall it from a usb drive?

Also wondering if this system is just very jacked up due to the way Double Take handled the migration.

Also wondering if this means my original server is really jacked up, but, the original server seems to run just fine, so not sure about that as the cause for the new server being so funky.
smckeown777Commented:
I'd say a lot of things aren't right since your migration...FixMyNetwork crashing, simple things not working(like the permissions stuff on this folder), there must be a ton of stuff not working properly

Is this a production server that is up and running and serving clients with shared folders - all that working properly and ok?
wfcrrAuthor Commented:
The "source" server is up and running. The "target" server is the one we are working on. When the migration and failover were performed Monday night, it became clear the "target" server wasn't working right, so I brought the "source" server back online and took the "target" server home.  

This is the second time we have tried using Double Take to migrate the server and had this exact same issue both times.  I was hoping we could identify a fix for the "target" server to remedy these issues so that I could do the migration and failover a 3rd time, then implement the "fix" and start using the new server. It is starting to look like there is just something fundamentally wrong with how Double Take is handling either the migration of the live production server to the new "target" server, or, the failover is messing stuff up.  

I wonder if we just close this question now and I'll take it up with Double Take?
smckeown777Commented:
Well step back a bit here - is the source server healthy? Before the migration I mean?

If not we need to fix that first...if yes then yes I'd agree something that DoubleTake are doing is breaking things...and you need to talk to them about it
wfcrrAuthor Commented:
Source server seems to be working fine.  Logged onto the source server and I can take ownership of that inf folder on it, SBS Console works and I can get to the Network/Connectivity and the Fix my Network wizard runs.
smckeown777Commented:
That answers the question then I'd  say
Whatever Doubletake is doing is breaking things badly

I'm not familiar with them but doesn't sound great

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wfcrrAuthor Commented:
Thanks for the help, guys! I awarded to both as looking at both areas brought me to the point of thinking the problem is with Double Take performing a very messy migration/failover.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.