It takes a long time to fully connect to access point after setting throughput to 144Mps

We recently installed new Cisco Aironet 2600 access points that are 802.11n capable.  They were operating at 54Mps, so I read how to increase the speed using WPA2 and WMM.  I was still having issues until I found a radio button under "Express Settings" called "Optimize Radio Network for:".  I selected the "throughput" option and now have the desired 144Mps.  However, now, when I connect my computer to the AP, it quickly shows "connected", but will take 40 seconds or more to "identify" the network, and then another 10 seconds to obtain Internet access.  I didn't have this issue when the speed was 54Mps.  I have tried looking through the settings and have read some documentation and posts, but haven't found what I am missing.  Is it possible to join the access point more quickly?
tmaususerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gheistCommented:
You need to allow more rates. It is not always clean air where you are.
0
tmaususerAuthor Commented:
Below are the rates showing in the config.  Are there more?  Am I misunderstanding?

I'm fine with 144Mps.  I think that is as high as we can go anyway without bonded channels.
My main concern is how long it takes for it to connect.  I'm sorry if I am causing confusion.

speed  basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15. m16. m17. m18. m19. m20. m21. m22. m23.
0
gheistCommented:
You have heavy loss at fixed maximum rate. Please allow lower rates too.
0
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

tmaususerAuthor Commented:
It looks like all the rates are enabled in this screenshot from the access pointData rates.  Am I looking in the wrong place?
0
gheistCommented:
Click on the button called "default" and return to factory antenna configuration.
0
tmaususerAuthor Commented:
Like this?
after clicking default
0
tmaususerAuthor Commented:
That dropped me back to 802.11g 54Mps.  I need 144Mps.  Not sure how to switch radio to factory.
0
tmaususerAuthor Commented:
Below is the config before changes:
!
! Last configuration change at 00:51:10 UTC Mon Mar 1 1993
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname GENERICNAME
!
logging rate-limit console 9
enable secret 5 "SECRETSTRINGHASH"
!
no aaa new-model
no ip routing
!
!
dot11 syslog
!
dot11 ssid GENERICSSID
   authentication open
   authentication key-management wpa version 2
   wpa-psk ascii 7 "HEXNUMBERS"
!
crypto pki token default removal timeout 0
!
!
username Cisco password 7 "MOREHEXNUMBERS"
!
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers aes-ccm
 !
 ssid GENERICSSID
 !
 stbc
 speed  basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15. m16. m17. m18. m19. m20. m21. m22. m23.
 channel 2437
 station-role root
 world-mode dot11d country-code US both
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 antenna gain 0
 dfs band 3 block
 channel dfs
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface GigabitEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
 bridge-group 1 spanning-disabled
 no bridge-group 1 source-learning
!
interface BVI1
 ip address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
 no ip route-cache
!
ip default-gateway xxx.xxx.xxx.xxx
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/blahblahblah
bridge 1 route ip
!
!
!
CONSOLE and TERMINIAL CONFIG OMITTED
!
end
0
gheistCommented:
Just remove line "speed"
Wat is the cleint card? e.g. centrino often goes with G rates for no reason.
0
tmaususerAuthor Commented:
Okay, I will try tomorrow.  It is an Intel(R) Centrino(R) Advanced-N 6200 AGN.
0
gheistCommented:
Then your client card is limited to 10 lowet rates AP announces. Try to get rid of all -B rates but 1Mbps to check.
0
tmaususerAuthor Commented:
deleting the speed line brought me back to 54Mps
0
tmaususerAuthor Commented:
b rates - is that 5.5 and 12?
0
gheistCommented:
2 5.5 11
0
tmaususerAuthor Commented:
How do I set the SSID to be broadcasted using the CLI?  In the web interface, it looks like I may have to delete and remake the SSID.  Had it set to not broad cast, but I what to see what happens with it visible.
0
tmaususerAuthor Commented:
Whenever I set a data rate to anything other than require, all of the MCS rates go to disabled.
0
gheistCommented:
Enable them back

SSID broadcast is called "Guest Mode" in GUI
0
Craig BeckCommented:
To enable the SSID to be broadcast in the CLI...

dot11 ssid GENERICSSID
   guest-mode

Open in new window


Stick the MCS rates back in and disable world-mode...

interface Dot11Radio0
!
 speed  basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15. m16. m17. m18. m19. m20. m21. m22. m23.
!
 no world-mode dot11d country-code US both

Open in new window


(Just paste it all in and try again)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tmaususerAuthor Commented:
So far I haven't had much luck with anything.  However, I did enable arp caching and it seemed that i could switch back and forth between networks faster if I did so quickly without letting it sit too long.
0
gheistCommented:
Your network card is broken. Buy 10$ USB network card to diagnose the issue.
0
tmaususerAuthor Commented:
I think figured it out.  I simply started over and made only the most basic settings, as 'craigbeck' was trying to point me in the direction of.  Now, within a few seconds, I am fully connected to the network at 144Mps.  My network card seems to be fine.
I did all of this from the web interface.
First, I reloaded the original WEP config, which was practically set to the defaults (I think other than the WEP setting and password, the only other difference was that 'Broadcast SSID in Beacon' was unchecked in 'Express Security').  
Then, in 'Express Setup', I selected the 'Throughput' option for 'Optimize Radio Network for:' .
Then, in the 'SSID Manage'r, I deleted the old SSID.
Then, in the 'Encryption Manager', I set the encryption to 'ciphers aes cmmp'.
Then, in the 'SSID Manager', I entered the new SSID name and selected Radio0-802.11N2.4GHz.
For the key management section of the SSID config, I set 'key management' to 'Mandatory' and checked 'Enable WPA' and set in to 'WPAv2'.
I didn't mess with WMM or the data and MCS rates.  WMM remained turned off, all of the data rates were set to 'Required', and all of the MCS rates were 'Enabled'.
Do these settings grossly violate any basic rules?  
Thank you both for your help!
0
Craig BeckCommented:
Sounds good to me.  You don't usually need to change WMM settings - they will allow 802.11n connections by default.
0
gheistCommented:
WMM is required for wifi-N certification, though most devices simply take no special action on it. But it may happen that client card falls back to Wifi-G not seeing WMM in the air.
0
tmaususerAuthor Commented:
I'll keep that in mind gheist.
Thank you both!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.