Voice Vlan Cisco Phones Not getting DHCP from 2911 Router

Hello,
    Everything else is working great. However, the voice VLAN on our new 3750-X Switch we just put in is not getting DHCP addresses from the router. Computers and other Vlan 1 devices are fine. Here is the relevant config from the switch:

!
interface GigabitEthernet1/0/26
 switchport access vlan 31
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport voice vlan 31
 mls qos trust dscp
 macro description cisco-router
 auto qos trust
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface Vlan1
 ip address 10.30.1.6 255.255.0.0
!
interface Vlan31
 ip address 10.31.1.6 255.255.0.0


And from the router:


ip multicast-routing
ip dhcp excluded-address 10.31.0.1 10.31.2.0
ip dhcp excluded-address 10.31.2.255 10.31.255.254
!
ip dhcp pool NC-VOICE
   network 10.31.0.0 255.255.0.0
   option 150 ip 10.41.1.11
   default-router 10.31.1.1
   domain-name domain.com
   dns-server 10.30.2.6 10.40.2.25
!

!
interface GigabitEthernet0/2
 description NC VOICE$ES_LAN$
 ip address 10.31.1.1 255.255.0.0
 ip nbar protocol-discovery
 ip pim sparse-dense-mode
 duplex auto
 speed auto
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 10.31.1.1
 service-policy input INPUT-MARK

Open in new window



Now, here is the weird thing. Before moving everything over to the new switch, I had it linked with the old switch. I then plugged a phone into the new switch, and everything worked. So I proceeded to move everyting over to the new switch, and that's when things stopped working.
JesusFreak42Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

td_milesCommented:
If you plug a PC/laptop into a switch port that is configured on VLAN 31 and give it a static IP address in the subnet for this VLAN, can you ping the router 10.31.1.1 ?
0
JesusFreak42Author Commented:
Yes
0
JesusFreak42Author Commented:
Actually, I am pinging it from vlan 1.... hold on
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

td_milesCommented:
Not sure if you want to advertise who you are, if you don't, then you might want to remove the domain name information from the DHCP scope.
0
JesusFreak42Author Commented:
OK. I just confirmed that I CANNOT ping it from VLAN 31. I gave my NIC a VLAN ID of 31 and an IP address of 10.31.1.234. I could not ping 10.31.1.1, though I can ping it from the wireless which is still on 1 with an address of 10.30.1.122.
0
td_milesCommented:
I just confirmed that I CANNOT ping it from VLAN 31.

You'll need to sort that out first then. If you have no connectivity on that VLAN to the router, then DHCP isn't going to work.

How is Gig0/2 on your router connected to your voice VLAN 31 ?
0
JesusFreak42Author Commented:
It is connected on the switch interface listed above, GE1/0/26.
0
td_milesCommented:
Unless you need it to be a trunk port for some reason, then I would change Gig1/0/26 to be an ACCESS port on vlan 31.

Once you do this, test if you can ping between your router & switch on VLAN 31. EG, from router try:

ping 10.31.1.6 source 10.31.1.1

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JesusFreak42Author Commented:
Still no luck. Here's the config for the switchport now:

interface GigabitEthernet1/0/26
 switchport access vlan 31
 mls qos trust dscp
 macro description cisco-router
 auto qos trust
 spanning-tree portfast
 spanning-tree bpduguard enable


Umm. I was just re looking over the Router config. I don't see any VLAN info.....
0
td_milesCommented:
I meant vlan 31 on switch, not router :)

Time for basics, is stuff up ?

show int gig0/2   (on router)
show int gig1/0/26  (on switch)
show int vlan 26  (on switch)

are they all showing as up ?
0
JesusFreak42Author Commented:
Yes, they are all up.


Results below. Thanks for your help, btw.


NC-2911#show int gig0/2
GigabitEthernet0/2 is up, line protocol is up
  Hardware is CN Gigabit Ethernet, address is f866.f234.f42a (bia f866.f234.f42a)
  Description: NC VOICE$ES_LAN$
  Internet address is 10.31.1.1/16
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full Duplex, 1Gbps, media type is RJ45
  output flow-control is unsupported, input flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:01, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 1000 bits/sec, 1 packets/sec
  5 minute output rate 42000 bits/sec, 2 packets/sec
     44537850 packets input, 321674544 bytes, 0 no buffer
     Received 1031624 broadcasts (831 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 704911 multicast, 0 pause input
     37893386 packets output, 1579990822 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     392142 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     3 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out


GigabitEthernet1/0/26 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is a46c.2a0c.cd9a (bia a46c.2a0c.cd9a)
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:46, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 19000 bits/sec, 1 packets/sec
  5 minute output rate 1000 bits/sec, 2 packets/sec
     241873 packets input, 252894710 bytes, 0 no buffer
     Received 1811 broadcasts (1230 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 1230 multicast, 0 pause input
     0 input packets with dribble condition detected
     299838 packets output, 57294425 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out
3750-1#show int vlan 26
                     ^
% Invalid input detected at '^' marker.

3750-1#show int vlan 31
Vlan31 is up, line protocol is up
  Hardware is EtherSVI, address is a46c.2a0c.cdc1 (bia a46c.2a0c.cdc1)
  Internet address is 10.31.1.6/16
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:46, output 00:01:32, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     24473 packets input, 5435294 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     10 packets output, 1242 bytes, 0 underruns
     0 output errors, 1 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
0
td_milesCommented:
So did:

ping 10.31.1.6 source 10.31.1.1

work ?
0
JesusFreak42Author Commented:
Yes!!! Thank you!!
0
td_milesCommented:
So is you DHCP working now, or just ping between the devices ?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.