issue with office 365 PST upload Tool - source file cannot be found

naidude
naidude used Ask the Experts™
on
Hello, I am able to successfully import the PST file using Microsoft Azure command line tool.  However when I create the PST mapping file, and then save as Csv and process the job, I get an error that says source file cannot be found.  Does anyone else have this issue?

azure file path: \\Asus_Beast\Users\John\Documents\pst\john_Live.pst
csv source file path: Asus_Beast/Users/John/Documents/pst/john_Live.pst

error message received after trying to process: Could not find source file Asus_Beast/Users/John/Documents/pst/john_Live.pst. Please correct the FilePath column in the mapping file and create a new job with the updated mapping file
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Raheman M. AbdulMessaging and Directory Services

Commented:
are you missing "\\" from the UNC path ?

csv source file path: Asus_Beast/Users/John/Documents/pst/john_Live.pst
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Should the CSV source file path not be pointing to a .CSV file rather than a .PST file?
Blue Street TechLast Knight
Distinguished Expert 2018

Commented:
Hi naidude,

Just for clarity you are talking about the Microsoft Azure AZCopy Tool, correct and not about MessageOps PST Importer Tool, MSFT Exchange PST Capture or something else?

Assuming that you are using the Azure AZCopy tool, you would run AZCopy once per source directory to upload all the files under those directories (including in all subfolders) into the Office 365 Staging Area.

The Source would be something like this: /Source:\\SERVER01\PSTshare1
The Destination would be like this: /dest:https://d1717df0c99e4157xyz520a.blob.core.windows.net/ingestiondata/SERVER01/PSTshareR1/

https://d1717df0c99e4157xyz520a.blob.core.windows.net/ingestiondata/” is the URL obtained above, “SERVER01/PSTshareR1/” is the source directory path converted into “Friendly Path” format.

Here is an example of the final:
AzCopy.exe /Source:\\SERVER01\PSTshare1 
/Dest:https://d1717df0c99e4157xyz520a.blob.core.windows.net/ingestiondata/SERVER01/PSTshareR1/ 
/Destkey:bVqiKup0j7Bxik39vSN/zV3UveKHWs
vmYb+NsvyoJs2Dhb8kOYIqmE2IPuC7uA7h3dTKJ1EmA0fWF3lPtBYtqA== /S /V:C:\PSTUpload\Uploadlog.log 

Open in new window

If you have multiple shared folders from which you wish to upload PSTs, such as \\SERVER01\PSTshare1 and \\SERVER01\PSTshare2, you may run the AzCopy tool multiple times and change the /source parameter to the appropriate folder each time.
 
Upload via CSV
In the FilePath column for each PST, enter the full “Friendly Path” to that PST. “Friendly Path” means take the path to the PST in your system, and change “\” slashes to “/” slashes, and remove leading slashes, for example:
pst “cy13.pst” stored at \\SERVER01\PSTshareR1\Aug1999PstFolder\cy13.pst, the FilePath column becomes SERVER01/PSTshareR1/Aug1999PstFolder
You can download the PST mapping file template here: http://go.microsoft.com/fwlink/p/?LinkId=544717

Let me know how it goes!
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Hello guys, thanks for all your feedback, however it hasn't solved my issue. I've followed the instructions in the csv mapping howto. I copied the exact path from the succesful azure pst upload and changed by removing leading slashes and switched the slash but no luck. My source path didn't include the pst file, that is defined in a separate column in the csv mapping file. Microsoft tech support calling me tomorrow morning. Let's see what they say.
Blue Street TechLast Knight
Distinguished Expert 2018

Commented:
Ok, I updated my last post. Please refresh the page and re-read.

I don't understand when you say this thought:
azure file path: \\Asus_Beast\Users\John\Documents\pst\john_Live.pst
csv source file path: Asus_Beast/Users/John/Documents/pst/john_Live.pst
These aren't supported paths in the CSV file. The columns separate the string into three separate columns. The columns should read:
Workload,FilePath,Name,Mailbox,IsArchive,TargetRootFolder,SPFileContainer,SPManifestContainer,SPSiteUrl

and your data respectively as such:
Exchange,Asus_Beast/Users/John/Documents/pst,john_Live.pst,john@domain.com,FALSE,user1_outlook files_john_Live,<LEAVE_BLANK>,<LEAVE_BLANK>,<LEAVE_BLANK>

Make sense?
Commented:
hello guys, the solution was quite simple. I didn't need a server path, just my local drive path

Workload      FilePath                                                   Name                                    Mailbox      IsArchive
Exchange      C:\Users\Krisen\Desktop\pst1      kkupp_Live.pst      kkupp@cisustms.com      FALSE

Author

Commented:
all the comments provided were very helpful, utlimately I had to call microsoft tech support who showed me how to use the local drive path and it worked. Even though I was able to upload my files with the azure cloud by using my machine name as the path, it didn't work with the pst mapping tool and said file not found.  by using the drive path, it worked.
hello ,
i have an issue in mapping my pst files
firstly i use this command
AzCopy.exe /Source:\\EXCH2013\pst ************************************

 at  verfiy mapping i dont know what the path i should use
EXCH2013/pst
EXCH2013\pst
EXCH2013/C:/pst
EXCH2013\C:/pst
kindly i need your help ASAP
Thanks

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial