HP Photosmart Premium C309A Protection Fault accessing Printer Properties and won't print (Windows 8.1 - 64bit)

My HP Photosmart Premium C309A, connected via USB, has been working fine through the life of Windows 7 and Windows 8.1, until this week.
 
I had been running the software in PS_AIO_05_C309a_Net_Full_Win_WW_140_408-4.exe and then this week I received notice that there was a software update. I downloaded and installed the new version, PS_AIO_05_C309a_Net_Full_Win_WW_140_408-5.exe (v 14.8.0), and now my printer won't print.
 
I uninstalled the previous version, with no errors, and installed this new version, also with no errors. But, when I click on Printer Properties I get a Protection Fault (attached)


If I try to print a test page, the system hangs for a couple minutes and then the Control Panel\All Control Panel Items\Devices and Printers page closes (with no messages).
 
I tried connecting via Ethernet instead, but that made no difference.
 
Interestingly, even though printing doesn't work, scanning and faxing do. I can connect and use the scanner with Paperport or Adobe Photoshop Elements.
 
I've uninstalled the software many times and tried both the old version and the new and they both do this.
 
I've tried running Print and Scan Doctor. That says that the driver is missing some files and to uninstall and reinstall, but I've done that at least 6 times with no luck.

Some other things I did to try to fix this:
 
- Ran CCleaner after each uninstall (several times) to clean up the registry.
 
- Deleted all the HP and Hewlett Packard directories that I could find located in
--Program Files,
--Program Files (x86),
--users\stan\appdata\Local,
--users\stan\appdata\Roaming
and
--ProgramData.

Any ideas?

BTW, I've been holding off upgrading to Windows 10 on this, my primary system, although I have done so already on my laptop and secondary system. I'm wondering if doing the upgrade would clean up any system corruption.

Stan
rosestAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nobusCommented:
try a system restore to a date it was ok
Spike99On-Site IT TechnicianCommented:
When you removed the software & re-installed, did you also completely remove the printer & any other devices connected with it from the Devices and Printers folder?  I would remove the printer, fax & scanner. Then, remove all drivers, uninstall the software & then reboot before re-installing anything.

If that doesn't resolve the issue, you could try the MS Printer Diagnostic tool. You can get that here:
http://go.microsoft.com/fwlink/p/?LinkId=260616

I hope this helps.
rosestAuthor Commented:
Thank you both, Nobus and Alicia.

I tried a couple more steps. I tried SFC /SCANNOW to see if there were any corrupted DLLs, but there were not, so I then attempted Nobus's suggestion of a restore to last week. Unfortunately, Restore claimed it couldn't find the old files, although I don't know why that would be.

So, before I saw Alicia's note, I decided I might as well do the Win 10 upgrade, since I did suspect it was a windows and not a printer driver problem. That, in fact, did fix it; I have a working printer again.

Alicia, I had made sure there were no printer or fax artifacts remaining in Devices/Printers. I also made sure there were none left in Device Manager. I hadn't however, tried the MS Printer Diagnostic as I didn't know that one. I had run the HP diagnostic and, as I mentioned in my first not, that had just told me to uninstall and reinstall.

Thanks again, both of you.
Stan

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rosestAuthor Commented:
One suggestion was to do a system restore, but I was not able to do that because windows said it couldn't find the older files. The other suggestion was to run the MS Printer Diagnostic but by then I had already fixed the problem by upgrading to Windows 10.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.