vRanger error 2712 - cant create the directory

Hello, Backups for VMs (esx 4.1) were running fine for months, no changes, vRanger 6.0 backup software. All of a sudden last night half of them stopped running with the following error: Error Message: 2712 - can't create the directory cifs. I checked and confirmed permissions are OK, rebooted vRanger server and the Netgear ReadyNas they backup to, and the job still fails with the same error. Any ideas? I looked at the dell support page and none of those 3 solutions seem to be my issue. I tried un bonding and bonding the 2 NICs on the NAS, recreating the vranger job, removing and re-adding permissions to CIFS share, nothing has worked.
Pig_TroughAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mr TorturSystem EngineerCommented:
Hi,
I don't think I can do a lot for you, but let's try!
But this is why I started to hate vRanger, as I installed it for several customers : everything is fine, and then a job fail. And sometimes it works again, and then not... Soooo capricious software.

Just some shots in the dark for your issue :

- check the vcenter (or ESX) credentials in vRanger inventory
- check if there is really no issue at all on your target (Nas), that disk space is available, user access, etc..
- you could try to reset more things than you already did by deleting/re-adding vcenter and ESX in vranger, and do the same with target repository (the Nas) in vranger repository menu, and then recreate the job.


If not resolving your issue you could try a vranger upgrade, specially if you have license for upgrade (you need to have bought the product and have been under support contract since).

Or switch to Veeam, as a lot of us, or other software.
To me vRanger is buggy, maybe less in latest version, but also it has really less option than Veeam : no tape support, less scheduling option, no application aware assistant for AD/SQL/exchange GRT, no boot VM from backup option, tuning options, etc.......... One of the only good point I find in vranger is that for replication its proxies don't need a windows license.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Pig_TroughAuthor Commented:
Thanks for the ideas. It ended up being an issue with the NAS, which was SO odd because i could easily navigate and copy/remove files from that share via windows explorer WITH THE SAME CREDENTIALS stored in vRanger. I reformatted share and it worked again so I assume vRanger screwed up the credential somehow.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.