Help removing and changing a driver in windows 7

On my Windows 7 laptop the USB3 port worked fine, from new, for about 6 months and then stopped working. It no longer recognises any USB devices but does have power as proven by inserting a USB mouse and observing it light up.

On the motherboard is a Fresco Logic (FL) 1000 PCIe - USB3 chip whose PnP Vendor code is 1B73 and its DEVICE code is 1000.

Enquiries to both the laptop and chip manufacturers have not born any useful suggestions as to go about fixing the problem. They did suggest that I revert the laptop to "Factory Settings" which I did, and it did not fix the problem (during the rebuild it did report one error which could be a side effect of the fault and the laptop manufacturer was not able to decode the error number for me).

In the Device Manager tree there is no hardware described as being of Fresco Logic origin but it does report a suspicious "PCI Express standard Root Port" which has a PCI address of 0,28,0 with no sub-device in the Dev Mgr tree.

I have googled and found many folk having identical fault scenarios on different laptop manufacturers all having the common issue involving the FL1000 chip. Only one person claims to have fixed his problem. I have tried applying all their fixes to no avail.

I cannot install the FL1000 driver as it reports "Fresco Logic USB3 Host Controller is not found!".

I concluded that the original Vendor/Device code 1B73/1000 has been changed to 8086/1c10 in the USB3 PCIe device registers and need to restore those registers back to 1B73/1000 before attempting to install the driver.

I am seeking advice advice on whether I am on the right track and pointers on how to go about completely removing the current driver, restoring the registers and replacing it with the original Fresco Logic driver.

Thanks in Anticipation

Loneaussie
loneaussieAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nobusCommented:
it looks like the usb 3 chip went bad : "it reports "Fresco Logic USB3 Host Controller is not found!".
"
you can test also by booting from a live knoppix cd - it may have the drivers needed
http://www.knopper.net/knoppix-mirrors/index-en.html      

you can also install another usb 3 controller :  http://www.amazon.com/Transcend-Express-Adapter-Laptop-TS-PNU3/dp/B003QJX1K8
0
☠ MASQ ☠Commented:
What's making you think the register for the USB3 Chipset has been changed?  The alternate Ven/Dev code you've quoted is for a Intel PCI-E Port. Might there be a problem with that component?

Power to the port doesn't mean much in terms of it working for comms but this is much more likely to be software than hardware getting messed up (doesn't rule out a blown component somewhere on the board though).

What mainboard/laptop are we talking about?
Have you got Windows Updates on automatic?  
Any chance of a new "more helpful" driver update having been installed without your knowledge (anywhere in the chain, your chipset drivers control how the board communicates with the USB root hub etc)?

Have you tried a system restore yet back to a date prior to the fault developing?
0
loneaussieAuthor Commented:
nobus and MASQ

Hi

Thanks for your prompt responses.

FYI - I live in timezone UTC + 9 hours - Melbourne, Australia.

By way of part introduction this upcoming September I will be celebrating my 50th anniversary of computer coding.


NoBus

I've dowloaded your suggested software and will be trialling it tomorrow morning. I'll advise on my findings.


MASQ


My laptop is an ASUS G74Sx having an Intel Core 7 processor with 16 GB RAM.

It is ideal for game playing but I find that it is superb for the type of work that I am involved with at the moment.

The chip spec shows that it is an all-in-one PCIe-USB3 chip. I have spent time studying the workings of PCIe and learnt about the memory required for registers that hold the PnP data. I saw from day 1 that the Dev Mgr correctly reported it as the Fresco Logic 1000.

In my researches I have deduced, by a process of elimination, that all but one on-board peripheral are correctly reported by the Dev Mgr and proven to be fully functional. The one not working being the USB3 port.

A common feature in the reports other folk have posted is a suspicion that a windows update may have changed the PCIe registers at some time. Curiously they report my findings that theirs too have changed to some sort of PCIe bridge or similar device.

So I have a "dangling" device on the PCIe bus (If it is disabled it does not affect the operation of any other peripheral).

It is only my conjecture at the moment, and I am open to any kind of advice or opinion.

I concur with your power/fault comments. I know only too well how hardware faults can let genies out of bottles and cause us to chase moon beams!

A system restore was attempted shortly after I noticed the failure but is was too late to be of any use. Basically I had no real cause to use the USB3 so the occurrence  slid under the radar.

This problem is well reported on the net and all the evidence points to the USB3 chip drivers.

Regards to you both

loneaussie
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

nobusCommented:
it cannot  be due to an update - since you reset it to factory default = a factory restore, which eliminates all updates
imo -  it has nothing to do with drivers - but i may be wrong here
0
loneaussieAuthor Commented:
nobus

I read some of the solutions that you have provided to other folks problems in the area of windows PnP and driver issues.

This has prompted me to re-state my problem in a different way.

My current thinking on what I want to achieve is as follows:

make the dangling PCI bus chip an unknown device in windows 7 (Yellow question mark over icon in Dev Mgr);

install Fresco Logic driver (done - see later);

associate the FL driver to the "unknown' device.


I have found FL drivers in the form held in a cab file, extracted them and installed them using pnputil. The installation was reported successful.

FL drivers also come in an exe file. If I execute the file it fails with the message "Fresco Logic USB3 Host Controller is not found!"

Questions arising:

Can I assume that the exe file method fails because windows does not see the chip with the correct DEV/VEN code.

Is the VEN/DEV codes installed by FL in firmware form so as to allow PnP detection?

Who defines where the FL chip is positioned in the PCIe tree (0,28,0), is it ASUS during build?

Thanks for your input thus far.
0
nobusCommented:
you cannot do it that way - the PCI bus MUST be running and installed
so i believe you just have a bad board
you can always verify if it runs fine by running from the Knoppix cd - and test the usb 3 , going on internet etc...
if it does not work - bad board as said
0
loneaussieAuthor Commented:
nobus

I now concur with you.

PCI devices have to be switched on before windows 7 does a full enumeration of the PCI tree on the motherboard and set up drivers for those devices.

My hypothesis now is:

Given that some event has happened that changed the VEN/DEV values associated with the FL1000 chip from 1B73/1000 to 8086/1C10 implies that there is a method to do the change.

Therefore it may be possible to revert the values back to 1B73/1000.

This assumes that there is NO hardware damage to the chip.

So my researches are moving towards finding ways of achieving such a change.

I haven't used Knoppix yet but I did use Ubuntu and it did not detect the FL but found the Intel device.

My first conjecture is that there is some firmware in the chip holding the VEN/DEV data. I will send an email to FL asking for confirmation. Hopefully they will reply but my last communication was ignored!

In the meantime I have used a bootable PCSniffer CD and it reported finding an Intel device on 0,28,0 requiring 4 areas of memory each only 16 bytes long. This is at odds with Win7 which actually reserves only 2 much larger areas of memory.

I have disassembled an FL1000 driver exe file and found an hidden string of data with 731B and 0010 embedded in it. It might be the initialise data for the chip.

Are you, or do you know of anyone in this group who is, a PCIe guru?
0
nobusCommented:
>>  I did use Ubuntu and it did not detect the FL but found the Intel device.  <<

did it also report the pci not working?
imo this is the reason you have this trouble
i would have the board repaired or replaced - is there any warranty left?
0
loneaussieAuthor Commented:
FYI - I have sent the laptop to the local ASUS agent and they are investigating the proble.

I will advise there findings when I get the laptop back.
0
nobusCommented:
it looks like a starnge one to me
i'm curious as to what result it gets
0
loneaussieAuthor Commented:
Update. ASUS have advised me that there is a fault on the motherboard and that they have ordered a new one. If there is one in stock I should have it back in a week, two weeks otherwise.
0
nobusCommented:
that's what i said; glad it is confirmed
0
loneaussieAuthor Commented:
The laptop has had a new motherboard installed. It was stable and working well with just the Factory Settings installation of Windows 7.

I installed all of the windows 7 64 bit updates, though NOT including any of the drivers from the Windows update site, and it was stable throughout the entire process.

I then tried installed the Fresco Logic FL1000 driver from the windows update site. It did not install correctly and in the Dev Mgr the FL USB Root Hub was flagged as not having a driver.

I recovered the Hub by re-installing the FL 3.0.119.1 Factory Settings driver.

Closure at last.

FYI -

There is still an unused PCI slot at 0,28,0 which I have disabled.

The Intel PCI bus slot that connects to the FL controller is on 0,28,3

The FL controller device is on PCI 4,0,0



Thanks to all for the steering advice received.
0
nobusCommented:
ok - don't forget to close this Q properly
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.