Sbs 2011 won't boot

I did a defrag on the OS drive which was quite fragmented. When the server rebooted, it went immediately to the recovery console. I can't get it to boot to Windows.

If I use bootrec to scan for OS it says there aren't any. However, if I'm at a command prompt, I can go to both the OS partition and the data partition. And see everything including a Windows directory.

Unfortunately I have to have this server up for this law office by 8 AM EST, so I'm a little panicked.

Thanks for your help.
wperdue72Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lee W, MVPTechnology and Business Process AdvisorCommented:
So the data is good accessible.  That's important - the drives haven't died.  When was the last time you did a system state backup.  You may have to restore.
wperdue72Author Commented:
They have a storagecraft shadowprotect server that is supposed to be backing everything up. I was just brought in recently to help with some IT issues (unstable servers for one), and haven't tested that backup yet as I've been putting out fires.

I do have some new information. I can get to startup repair now. For some reason the OS partition was marked as active. Once I changed that, startup repair is an option and it can see the installed OS. The problem is, there is some kind of Dell recovery partition (39MB FAT) that is marked as active. It now says it's drive "C" and the original OS partition is now marked as "F" (and shows as such in the recovery console).

If I boot without touching anything, I get a Dell DMRK v8.00 prompt with just command.com available. If I use that CD I have with a boot manager, I can select partition 2 (recovery) and it will boot to the recovery options. If I select partition 3 (OS) I get "bootmgr is missing or corrupt).

I can then boot from a CD with a boot manager utility, select partition 2 and try startup repair. It has run three times. The first time it said the partition table was screwed up and it repaired it. The second time, it found problems with the boot loader (if I remember correctly). The third time, it went through a long process and said that vmbus.sys and winhv.sys are corrupt and cant' be fixed automatically.

Thanks again for your help.
David Johnson, CD, MVPOwnerCommented:
have you tried bcdboot x:\windows  where x: is the drive letter for the os partition in the recovery console?
Check Out How Miercom Evaluates Wi-Fi Security!

It's not just about Wi-Fi connectivity anymore. A wireless security breach can cost your business large amounts of time, trouble, and expense. Plus, hear first-hand from Miercom on how WatchGuard's Wi-Fi security stacks up against the competition plus a LIVE demo!

wperdue72Author Commented:
I get winhv.sys not found or corrupted. 0xc000098.
noxchoGlobal Support CoordinatorCommented:
How many partitions do you have on the drive? Which of them contain BootMgr file and Boot folder? The partition that has this data must be active.
QuarmCommented:
On SBS you can do a recover to a last good config - Have you tried that?

Or get to recovery console and then

Shift + F10 to popup the Command Prompt
bootrec /scanos
bootrec /rebuildbcd
wperdue72Author Commented:
There were 4 partitions on the drive. A 39MB Dell partition, 120 GB OS, 200MB system reserved (which we created), and an 800GB data partition.

I tried last known good configuration, and it had the same result as well as every variation of bootrec and startup repair.

After restoring backups of SAM, SYSTEM, etc. I was able to get it to boot to a black screen with a cursor where it would then reboot.

I also spent 12 hours on the phone with Microsoft parallel to this conversation with no luck.

I had to restore the OS from a block level backup to a new drive because there was not enough space on the old one after shrinking it by 200MB for the system partition. That brought it back and I was then able to use the secondary drive with the data to get them back up. Exchange logs were available for the day of the restore, so after swapping around a few drive letters, the information store mounted properly.

Thank you all for your help and suggestions. I'll definitely be sticking around with a membership, and hope to be able to answer some questions myself.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IT Administration

From novice to tech pro — start learning today.