hsrp and spanning tree

I have the setup below (see pic). I have core 1 as the primary hsrp gateway for vlan24 10.2.24.1/24 and core 2 as the primary hsrp gateway for vlan120 10.2.120.1/24. But when I look at the spanning tree, it is all going through core1 because spanning tree blocks fa0/2 for both vlans on switch1. How do I fix this to allow fa0/1 as the primary path for vlan24 and fa0/1 as the primary path for vlan120.

pic
LVL 1
leblancAccountingAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RafaelCommented:
Can you provide more details like a config for core 1, core 2 as well as what type of switches they are ?
leblancAccountingAuthor Commented:
The cores are Cisco Catalyst 3750s. Switch0 is a Cisco Catalyst 2960S. The configs are very basic (see below)

switch1:
...
interface FastEthernet0/1
 switchport mode trunk
!
interface FastEthernet0/2
 switchport mode trunk
!
...
!
interface Vlan1
 no ip address
!
interface Vlan120
 ip address 10.2.120.100 255.255.255.0
...
ip default-gateway 10.2.120.1

Open in new window


core1:
interface gig0/0
 switchport mode trunk
!
interface gig0/2
 switchport mode trunk
!
...
interface Vlan1
 no ip address
!
interface Vlan24
 ip address 10.2.24.2 255.255.255.0
 standby 1 ip 10.2.24.1
 standby 1 priority 200
 standby 1 preempt
!
interface Vlan120
 ip address 10.2.120.2 255.255.255.0
 standby 1 ip 10.2.120.1
 standby 1 preempt
...

Open in new window


core2:
interface gig0/0
 switchport mode trunk
!
interface gig0/2
 switchport mode trunk
!
...
interface Vlan1
 no ip address
!
interface Vlan24
 ip address 10.2.24.2 255.255.255.0
 standby 1 ip 10.2.24.1
 standby 1 preempt
!
interface Vlan120
 ip address 10.2.120.2 255.255.255.0
 standby 1 ip 10.2.120.1
  standby 1 priority 200
 standby 1 preempt
...

Open in new window



SH SPAN FROM SWITCH0:
 VLAN24 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address cc03.1e68.0001
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 32768, address cc01.1cd4.0001
  Root port is 41 (FastEthernet0/1), cost of root path is 19
  Topology change flag not set, detected flag not set
  Number of topology changes 3 last change occurred 01:57:36 ago
          from FastEthernet0/2
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300

 Port 41 (FastEthernet0/1) of VLAN24 is forwarding
   Port path cost 19, Port priority 128, Port Identifier 128.41.
   Designated root has priority 32768, address cc01.1cd4.0001
   Designated bridge has priority 32768, address cc01.1cd4.0001
   Designated port id is 128.81, designated path cost 0
   Timers: message age 1, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 30, received 4306

 Port 42 (FastEthernet0/2) of VLAN24 is blocking
   Port path cost 19, Port priority 128, Port Identifier 128.42.
   Designated root has priority 32768, address cc01.1cd4.0001
   Designated bridge has priority 32768, address cc02.173c.0001
   Designated port id is 128.81, designated path cost 19
   Timers: message age 3, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 16, received 4316


VLAN120 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address cc03.1e68.0002
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 32768, address cc01.1cd4.0002
  Root port is 41 (FastEthernet0/1), cost of root path is 19
  Topology change flag not set, detected flag not set
  Number of topology changes 3 last change occurred 01:59:52 ago
          from FastEthernet0/2
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300

 Port 41 (FastEthernet0/1) of VLAN120 is forwarding
   Port path cost 19, Port priority 128, Port Identifier 128.41.
   Designated root has priority 32768, address cc01.1cd4.0002
   Designated bridge has priority 32768, address cc01.1cd4.0002
   Designated port id is 128.81, designated path cost 0
   Timers: message age 1, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 30, received 4371

 Port 42 (FastEthernet0/2) of VLAN120 is blocking
   Port path cost 19, Port priority 128, Port Identifier 128.42.
   Designated root has priority 32768, address cc01.1cd4.0002
   Designated bridge has priority 32768, address cc02.173c.0002
   Designated port id is 128.81, designated path cost 19
   Timers: message age 3, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 17, received 4380

Open in new window

Don JohnstonInstructorCommented:
But when I look at the spanning tree, it is all going through core1 because spanning tree blocks fa0/2 for both vlans on switch1. How do I fix this to allow fa0/1 as the primary path for vlan24 and fa0/1 as the primary path for vlan120.
You would make Core 1 the root bridge for VLAN 24 and Core 2 the root bridge for VLAN 120.

Core 1
spanning-tree priority vlan 24 priority 4096

Core 2
spanning-tree priority vlan 120 priority 4096

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
leblancAccountingAuthor Commented:
Yes. That's it. Thx
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Architecture

From novice to tech pro — start learning today.