Exchange 2010 search not returning any IRM email.

From what I can see all settings for IRM seem to be correct.
Transport rule passed
OWA passed
Outlook on-premise passed

[code]Search-mailbox -SearchQuery {subject:"*Daily Revenue*" AND received:8/23/2015} -deletecontent -force[/code]

This returns no results.

The same thing happens when in outlook connected to an Online Mailbox.
LVL 26
yo_beeDirector of Information TechnologyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

systechadminConsultantCommented:
PLease check the Eventlogs on the server for any issues
0
systechadminConsultantCommented:
Also make sure that IRM licensing is enabled. Please check the below link for your reference
http://exchangeonline.in/enable-irm-licensing-for-internal-messages-in-exchange-2010/
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
yo_beeDirector of Information TechnologyAuthor Commented:
So I tried and was able to search my mailbox after I did a rebuild of the Index for that DB, but once the crawl was done the items were no longer returned

I noticed something with this.  It stopped on 8/15/2015 the day I disable IRM, removed the DRM folder and re-enabled IRM.  

I did a IISRESET, but something must have been out of sync.  


I am going to copy the rights protect (DRM) folder back and see what happens.
0
yo_beeDirector of Information TechnologyAuthor Commented:
To add to the confusion or maybe it is pointing me in the right direction.
It seems that emails that are protected with ADRMS manually by the user (From within Outlook) are searchable, but emails that are protected using a transport rule are not.

So we now really need to focus on the Exchange server.
0
yo_beeDirector of Information TechnologyAuthor Commented:
I rebuilt the IRM configuration and it started to work after the cache was refreshed.

Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.