Unable to start W32Time service in Windows Server 2008 R2 ?

People,

All in a sudden that I see, the time from my Physical box Windows Server 2008R2 is drifting 3-4 minutes, so I tried to restart the time service, but somehow it is having this error:

---------------------------
Services
---------------------------
Windows could not start the Windows Time service on Local Computer.

Error 1290: The service start failed since one or more services in the same process have an incompatible service SID type setting. A service with restricted service SID type can only coexist in the same process with other services with a restricted SID type. If the service SID type for this service was just configured, the hosting process must be restarted in order to start this service.
---------------------------
OK  
---------------------------

Why is that happening ?
LVL 11
Senior IT System EngineerIT ProfessionalAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Senior IT System EngineerIT ProfessionalAuthor Commented:
This is the script that I run as Administrator but still failed:

net stop w32time
w32tm /unregister
w32tm /register
net start w32time

w32tm /config /syncfromflags:domhier /update
w32tm /resync /rediscover
net stop w32time
net start w32time

pause

Open in new window


this is the error message:
C:\Windows\system32>net stop w32time
The Windows Time service is not started.

More help is available by typing NET HELPMSG 3521.

C:\Windows\system32>w32tm /unregister
The following error occurred: Access is denied. (0x80070005)

C:\Windows\system32>w32tm /register
The following error occurred: The specified service has been marked for deletion. (0x80070430)

C:\Windows\system32>net start w32time
System error 1058 has occurred.

The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.


C:\Windows\system32>w32tm /config /syncfromflags:domhier /update
The following error occurred: The system cannot find the file specified. (0x80070002)

C:\Windows\system32>w32tm /resync /rediscover
The following error occurred: The service has not been started. (0x80070426)

C:\Windows\system32>net stop w32time
The Windows Time service is not started.

More help is available by typing NET HELPMSG 3521.


C:\Windows\system32>net start w32time
System error 1058 has occurred.

The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.


C:\Windows\system32>pause
Press any key to continue . . .
TimorosCommented:
To resolve this problem, follow these steps:

    Click Start , type regedit in the Start Search box, and then click regedit.exe in the Programs list.
    If you are prompted for an administrator password or for a confirmation, type your password, or click Continue .
    Locate the following registry subkey, and then click it:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TapiSrv
    In the details pane, right-click ImagePath , and then click Modify .
    In the Value data box, type the following registry value, and then click OK :
    %SystemRoot%\System32\svchost.exe -k NetworkService
    Note If NetworkService does not appear in the %SystemRoot%\System32\svchost.exe -k NetworkService registry value, the problem that is described in the "Symptoms" section may occur.
    Exit Registry Editor, and then restart the computer.

    Note If you try to start the Telephony service before you restart the computer, you may receive the following error message:
    Error 1290: The service start failed since one or more services in the same process have an incompatible service SID type setting. A service with restricted service SID type can only coexist in the same process with other services with a restricted SID type. If the service SID type for this service was just configured, the hosting process must be restarted in order to start this service.

*Before you do anything you should get a backup of your registry

Check this also:
https://support.microsoft.com/en-us/kb/816042#bookmark-letmefixitmyselfalways1
Senior IT System EngineerIT ProfessionalAuthor Commented:
Why is that Telephony  service ?

the problem is in Windows Time not Telephony .
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

TimorosCommented:
Note: I mentioned in case you have Telephony service installed as well ;)

Just try this

1. Click Start , type regedit in the Start Search box, and then click regedit.exe in the Programs list.
If you are prompted for an administrator password or for a confirmation, type your password, or click Continue .
2. Locate the following registry subkey, and then click it:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TapiSrv
3. In the details pane, right-click ImagePath , and then click Modify .
4. In the Value data box, type the following registry value, and then click OK :
%SystemRoot%\System32\svchost.exe -k NetworkService
Note If NetworkService does not appear in the %SystemRoot%\System32\svchost.exe -k NetworkService registry value, the problem that is described in the "Symptoms" section may occur.
5. Exit Registry Editor, and then restart the computer.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
systechadminConsultantCommented:
Open the command prompt as administration and run the below command

sc config w32time type= own
Senior IT System EngineerIT ProfessionalAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for ITSystemEngineer's comment #a40945382
Assisted answer: 167 points for Timoros's comment #a40945424
Assisted answer: 167 points for Timoros's comment #a40945439
Assisted answer: 166 points for systechadmin's comment #a40945471

for the following reason:

Thanks guys
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.