Problem with Java bypassing Windows security in CITRIX deployments

Hi,

I have a problem in our CITRIX deployment, where the GPOs that we have applied to the AD do not get followed by the Java Console.

We have the local windows server drives hidden by windows policy, but when an Application gets executed through CITRIX, it regains access to the hidden drives when using the "save as form".

If Java cannot be forced to follow GPO's, does anyone know how to take off access to drives from the Java console?.

Thanks.
LVL 11
Carlos IjalbaIT Systems DirectorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sekar ChinnakannuStaff EngineerCommented:
You want to hide the drives on xenapp server while users trying to save as right or client side?? Also may i know the xenapp version.
Carlos IjalbaIT Systems DirectorAuthor Commented:
Yes, that's the problem.

We have hidden the drives on windows server on the GPO's, but when using Oracle Forms application and trying to save a file, it opens up the java prompt "Save as..:" which shows all the server drives.

So users, go and save documents on the servers C: drive and then cannot open them from the explorer.

The XenApp is v7.6.
Sekar ChinnakannuStaff EngineerCommented:
You can use HideCalc 2.0 tool to hide the same, It support both 2008 & 2012. To download http://www.dabcc.com/downloadfile.aspx?id=20

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Carlos IjalbaIT Systems DirectorAuthor Commented:
Hi,

We have tried it, but it hasn't worked. However the process is not trivial and there isn't an easy to follow documentation out there to do it.

There is one step-by-step in EE, but is old and contains deprecated URLs.

We have applied the Loopback user control in replace mode, if that helps.

What's the easiest way to test it? because the output from gpresult is far from nice.
Carlos IjalbaIT Systems DirectorAuthor Commented:
Thanks Sekar,

At the end we managed to use it effectively, but we had a few issues applying the right policies, etc.

There was some step by step solution links otherwise in EE, but the links are now obsolete.

Thanks again for the solution.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.