Exchange SVR - Auto Reply rule messages not delivered.

I have 2 Exchange server 2013 Std stand alone boxes in two separate forests managing mail for separate domains.

One works 100% the other has a problem with OOF auto replies. I have confirmed the automatic replies are enabled and set to ExternalLegacy. When I examine message logs for a sender I can see entries with EventId - MAILBOXRULE and the mail has a subject prefixed with "Automatic Reply:" but the auto reply mails are never sent \ delivered to either internal nor external contacts.

I have confirmed there is nothing on our firewall, both servers go through the same firewall. I have also confirmed the Smart Host we relay through does not have anything to do with it as both send connectors use the same smart host.

Only difference between servers is patch levels. Yup you guessed it, the fully patched up to date server has the issue? Checking now if I can roll back...

Any ideas and help would be greatly appreciated.  Users are getting grumpy!
Raymond DurrettTechnicianAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

systechadminConsultantCommented:
Can you please share the tracking logs
0
Raymond DurrettTechnicianAuthor Commented:
Hi Gaurav.

Thanks you for you reply. Please find log attached.

Please find log attached for a user who reported this issue.

NOTE: What I can't understand is the the 'ReturnPath' for messages with subject prefixed with 'Automatic Reply:' in the log is always '<>' but on my working exchange 'ReturnPath' is always populated with the users email address that sends the OOF message. You will also notice there is only ever two processing log entries for any 'Automatic Reply:' message in this log. On the working exchange there are many steps to the process and they always end in 'SMTP - SEND'

All other mail into and out of this exchange is processed fine but anything to do with a rule \ transport rule is not working?
SenderLog.xlsx
0
Raymond DurrettTechnicianAuthor Commented:
Update...I found the problem here and it was AD permissions.

For exchange 2013 cross functionality with 2007/2010 there is a new AD group called ‘ExchangeLegacyInterop’ which is used for Exchange 2007/2010 functionality. I found permission issues on the default receive connector in my Active Directory schema.

By default the permission called ‘Accept Organization Headers’ on the default receive connector it is set to deny for the ‘ExchangeLegacyInterop’ group. I set this to allow and still there were problems.
I then read that users had reported problems with exchange 2013 update CU5 and OOF and had to remove all options for the ‘Accept Organizational Headers’ security permission for it to work. I can confirm that this has resolved the issue for me!

See attached file...

I also confirmed with my smart host company that they were allowing mail to send using Return-Path:<>  (=empty) as is done for auto replies in Exchange 2013. See below article…

http://www.techieshelp.com/exchange-2013-autoreply-replying-external-senders/
Exchange.png
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Raymond DurrettTechnicianAuthor Commented:
Resolved issue by own troubleshooting.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.