DNS not resolving certain domain and also slow load times

I have ran into a few problems. The first started happening Friday afternoon last week and that issue is that it taking 5-6 minutes for a user to login to their local computer after typing in their password. The user is logging into a server 2008 r2 setup with active directory / dns / dhcp. This is happening on every local user/machine that logs into the server. Once they get in, network shares / network printers work fine.

I have double checked dns settings. Local ip set for dns servers, 2 isp dns servers are set on the router.

Also, I am having issues with our domain.com not loading correctly on the same machines. Sometimes it will load fine but then reboot and it just times out on this specific domain. I have an A record setup in DNS and pointing to the webserver ip as the domain name is also the same domain on server (I know it shouldn't be this way but was already setup).

This issues started happening when our webhost upgraded us to cpanel and we had an issue with one page not loading for people due to a .htaccess file. That was resolved and host said ok, just flushdns and the pages should start loading. I do that and it works for a while, then the next day it would be back to the same issues of timing out on the domain.com. This has been going on for over a week now as I gave it time for DNS to hopefully update through everything. I have power cycled the router but that didn't seem to do anything.

Any ideas? Thanks!
ZephyrMAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bas2754Commented:
Did you verify that the IP in DNS is still the same as the one set in CPANEL?  I have seen ISPs change the IP when they change the plan settings.  This may be causing the problem with domain.com.  Now internally open up Event Viewer on your server and check the following:

Under Event Viewer->Application and Service Logs:
- DNS Server
- Directory Service
- DFS Replication

Errors with AD will prevent DNS from loading properly.  In addition do all of your computer ONLY point to the AD server for DNS or do you have it pointing to the AD server and your router or ISP?  You should only use your internal WIndows DNS server for DNS resolution in a Windows domain and then user forwarders on the DNS server(s) to point to your ISPs DNS server.

My guess is the IP for domain.com got changed and some systems are using an external DNS server to resolve and that is why they are able to see it, where others internally are using the internal DNS or cached names or even (in rare cases) and entry in their local c:\windows\system32\drivers\etc\hosts file that points to the website domain.com.  

Also, is your internal domain the same as your external domain - that can cause some rather large issues as well.  They can be worked around, but definitely can cause a problem.  Also make sure that you have a pointer for both www.domain.com and domain.com (assuming domain.com is different that internal domain) as sometimes when the cpanel change happens they will switch it from one to the other.

Get back with some details and we can try to help more.

From a problem PC that cannot log in:

Run the following from a command line:

ping internaldomain.local
ping domain.com
ping www.domain.com

From a system that works, do the same.  Does the resulting IP match what you would expect to see?  Internadomain.com should point to one of your AD controllers.  domain.com and www.domain.com should point to your webserver's IP.  From a system outside your network ping domain.com and www.domain.com.  Are the results the same?

Let us know the above and we should be able to narrow down the problem.
0
ZephyrMAuthor Commented:
Ok a little update. It does look like the webhost had changed the IP (twice actually with cpanel upgrade. I had the first change on the server but not the second.

As far as the other issue with slow loading times. It does appear to be a DNS issue. If I enter our local server that handles dns 192.168.0.2 on the local machine network adapter boot up times after typing user password is normal. If I remove the 192.168.0.2 from the adapter it goes back to be very slow.

To answer your previous questions. Local domain is the as external domain that loads our website. I know that is the incorrect way of having it setup but right now there is no going back. To get around that issue and our website loading for users locally, I setup a new A record setup.

DNS settings on the server are 192.168.0.2 and then forwarders setup to both of our ISP dns addresses.

I will dig into the log files shortly.
0
bas2754Commented:
So you need to check your DHCP server to make sure it is handing out 192.168.0.2 as the DNS server for all of your workstations or if the IPs are statically assigned you need to use that as the DNS server.  For the domain, you cannot make the A record for domain.com point to an IP other that your internal server.  Well, you can, but that will break a lot of things.  My suggestion is to make sure the site responds and lives on www.domain.com and just create an A record for www.domain.com.  We have 2 clients that have this same problem and that is what we have done since they did not want to pay to migrate to a subdomain for their internal network.

Let me know what else you may need.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
footechCommented:
So, with your internal and public domain being the same, it is not a problem to have a record for "www.yourdomain.com" pointing to the external IP, but you should not have a record for "yourdomain.com" pointing at an external IP.  You should only have A records for "yourdomain.com" which point at your domain controllers - any others and you will have problems.  This is just confirmation of what bas2754 already mentioned.
0
ZephyrMAuthor Commented:
DHCP did have the ISP dns before the internal one so that is what was causing that issue. Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.