SQL Server Reporting Service: Open SSRS reports give blank screen

Hi Folks,

I've an application to open reports but once click on hyper link of report then it gives blank screen.

Please note, I am able to access reports from public URL and same report server but not through website.

Best Regards,
Mohit Pandit
LVL 5
MohitPanditAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Vitor MontalvãoMSSQL Senior EngineerCommented:
Which browser are you using? Did you try with a different browser (IE, Chrome, Firefox, ...)?
0
MohitPanditAuthor Commented:
Yes, I tried on different browsers.
As, when I was trying to access through public IP of report manager then it works BUT not through ASP.NET

Best Regards
0
Jim HornMicrosoft SQL Server Developer, Architect, and AuthorCommented:
You're going to have to give us some screen shots of where this report is located on your SSRS server, and the link you're clicking, on order for this to be an actionable question.  Mind readers we are not.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

MohitPanditAuthor Commented:
Thanks guys.
Actually, problem was below two .dll files were missing in GAC.

Microsoft.ReportViewer.Common
Microsoft.ReportViewer.WebForms

I've added in GAC and bin directory and add handler in IIS with below step:

1.      I’ve added a handler in IIS. Please find below steps

Open Internet Information Services (IIS) Manager and select your Web application.
Under IIS area, double-click on Handler Mappings icon.
At the Action pane on your right, click on Add Managed Handler.
At the Add Managed Handler dialog, enter the following:
Request path: Reserved.ReportViewerWebControl.axd
Type: Microsoft.Reporting.WebForms.HttpHandler
Name: Reserved-ReportViewerWebControl-axd
Click OK.
Please note, handler will also be added in web.config after this setting under system.webserver’s handler section.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MohitPanditAuthor Commented:
Thanks
0
Jim HornMicrosoft SQL Server Developer, Architect, and AuthorCommented:
Thanks for posting your complete solution, we appreciate it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SSRS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.