Outlook sends winmail.dat to iphones and Mac instead of ICS calendar

We moved from an on-premise Exchange 2007 to Office 365. Now when we send an ics calendar, the iphone and MACs receive it as a winmail.dat file. The receiving email accounts are mixed, Yahoo, Gmail, earthlink, etc., all with the same problem. Before with Exchange 2007 we did not have this problem. We tested from Outlook 2010, 2013, same results.

We accessed the webmail portion of each receiving account and the attachment comes in fine. We also disabled TNEF in the registry, setup Outlook to send in plain text and configured the contacts to send in plain text as well. If we send from the Outlook Web App with Office 365 the attachment shows up fine. So the combination of Outlook and Mac/iphone is having the problems. By the way, the we tried with an Exchange account on the phones and those accounts receive them fine, just the other Gmail, Earthlink, Yahoo accounts don't.

Any suggestions?
NRTCFAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Vasil Michev (MVP)Commented:
You need to do this server side. Check for example here: https://support.microsoft.com/en-us/kb/2487954
NRTCFAuthor Commented:
thank you for the suggestion, that solution will not work since we have to create contacts every time and implement the solution. Are there any other suggestions?
Vasil Michev (MVP)Commented:
The solution will work just fine if you read the article to the end :)

You can control this on a per-domain basis, so you can easily adjust the setting for every contact in partner domain. Or even for *all* domains via:

Set-RemoteDomain Default -TNEFEnabled $false

Open in new window

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.