Protected View This file originated from and Internet location

I have redirected folders using Samba4 AD/DC. When opening many of the 'My Documents' files I get the message, "Protected View This file originated from and Internet location and might be unsafe." However, for many other documents in the same folder I get no such message. It should be noted that these files did not originate from the Internet and were mostly created in situ right in the My Documents folder.

I've checked file ownership, permissions, ACLs, everything I can think of and can find no difference in attributes between the documents that give this message and those that do not. I would like to know how Windows is making this determination so I can turn on or off whatever attribute is involved.

I do have instructions on disabling the Protected View feature altogether, but I'd rather not do that. I'd rather figure out what triggers this notice and clear it for the files in question.
LVL 1
jmarkfoleyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jcimarronCommented:
jmarkfoley--
This message almost occurs when opening a file in a component of MS Office. So I do not know if this will help.
http://www.askvg.com/how-to-disable-protected-view-in-microsoft-office-while-opening-email-attachments-or-downloaded-files/
0
jmarkfoleyAuthor Commented:
Yes, this happens when opening Word documents in particular. I do have links on how to turn it off completely including one I found: http://its.isber.ucsb.edu/troubleshooting/office-2010-documents-open-protected-view, but as I stated in my initial posting, that's not what I want to do. I want to understand why these files are being flagged for Protected View. Both your link and mine list several reasons for getting this notice:

◦This file originated from an Internet location and might be unsafe
◦This file originated as an e-mail attachment and might be unsafe
◦This file was opened from a potentially unsafe location
◦Editing this file type is not allowed due to your policy settings
◦Editing this file type is not recommended due to your File Block settings in the Trust Center
◦Office has detected a problem with this file. Editing it may harm your computer

So, these files did not originate from the Internet and did not originate as email attachments.

The 'location' is "My Documents", which physically resides on the Redirected Folders on the AD/DC. That shouldn't be a "potentially unsafe location." Furthermore, other documents in the same location open without this notice -- so it's not the location per se.

Likewise, it doesn't seem likely that it's a policy setting or File Block in the Trust Center else I would have problems with all files of that type.

Once I click on 'Enable Edit', I no longer get this message, even if I don't resave the file.

So, Windows must have some file attribute somewhere indicating the file should be opened in Protected Mode.

What makes Word think the document came from the Internet? What makes Word think the document was an email attachment?

There must be some attribute stored with or associated-with the file that leads Word to these conclusions and that Word can clear.

I've compared before and after "Enabling" versions of the same file, byte-by-byte and there are no differences (and no difference in md5sum), so the elusive 'attribute' is not stored in the file itself.

Any ideas?
0
jcimarronCommented:
jmarkfoley--
The first sentence in my earlier post should read
"This message almost always occurs when opening a file in a component of MS Office"
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

jmarkfoleyAuthor Commented:
So, what are you saying? Office makes this determination internally? I assume that, but the question is what *I* can do about this.

Specifically, after clicking "Enable" to this notice I never see the message again for that file, whether or not I actually modify or save the file. Office/Word must be setting some indicator somewhere so it knows not to show the "Protected View" alert the next time I open it. What is this indicator? I'd like to be able to clear/set this for all files in a batch job rather than either turning off "Protected View" mode altogether or Enabling each file one-by-one as I encounter them.
0
jmarkfoleyAuthor Commented:
Actually, I figured it out, finally. The location has to be added to the Trust Center. In Word: File > Options > Trust Center > Trust Center Settings > Trusted Locations. Click 'Allow Trusted Locations on my network'. Click 'Add New Location'. Type in name of redirected folders:
Trust CenterThat solved the problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jmarkfoleyAuthor Commented:
I figured it out
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.