Wireless Issue on Dell 7450

Hello,

I am trying to dual boot a linux environment on my Dell Latitude 7450 with a Intel Dual Band Wireless-AC 7265 network card. I have, so far, tried Fedora 22, CentOs 7, and Ubuntu 14.

The problem I am having is connecting to a 802.1x network at my office. We are using an AeroHive system for our wireless routers. They are configured to authenticate against Microsoft AD.

The wireless setup is PEAP, No cert required, and MSChap v2. I can connect to the wireless network perfectly with my Windows 7 dual boot of the machine. I can also connect to the wireless with a Android and iOS based phone. So I know the wireless works fine without it being a Windows based system. The other issue I see is if I connect to our guest network it is very unstable.

When I try to connect via Linux I get one of 2 different error scenarios: 1) It just does nothing, no error or anything, just a timeout or 2) it repeatedly asks me for my credentials.

I am fairly new to linux and am trying to make Linux my main OS to use it everyday. In order for me to do that I need to get this one last piece working.

If anyone can shed some light on what might be going on I would greatly appreciate it.
SatuittechAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SandyCommented:
It must be either network driver issue or the firmware issue of laptop, This hardware is quiet common in triggering the issues while working on Linux flavors.

Try updating the firmware of network interface once.

TY/SA
0
SatuittechAuthor Commented:
The laptop itself already has the latest and greatest firmware. I know there are at least 2 other newer versions of the network driver/firmware for linux out there but I do not know how to get Fedora to use them. I copied them to the lib/firmware folder where the other drivers were located but it doesnt automatically take the new one.
0
SatuittechAuthor Commented:
I tried another laptop I had here in the office and put Fedora 22 on it, it seems to have connected perfectly fine to the corporate network. The only difference is the network card, my laptop has a Intel 7265 in it and the other laptop has a broadcom wireless nic.
0
Duncan RoeSoftware DeveloperCommented:
The kernel will not use [new] drivers it doesn't know about. Fedora 22 is 18 months old and past end-of-life.
Try with Fedora 25 (current release)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Duncan RoeSoftware DeveloperCommented:
The author has not seen fit to respond, so we have to assume the solutions have worked for him. He has 3 days to object if not
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.