WSUS clients not working

OK I have researched other peoples issues on EE and nothing seems to be working for me on this.  My PCs have not updated from the WSUS server in two months.  I looked at the WSUS server and all appears fine.  It has synchronized the last 90 days and I see many updates that it pulled down.  In reading all the posts, I did run the wsus diag tool and the results are below:

--------------
WSUS Client Diagnostics Tool

Checking Machine State
        Checking for admin rights to run tool . . . . . . . . . PASS
        Automatic Updates Service is running. . . . . . . . . . PASS
        Background Intelligent Transfer Service is running. . . PASS
        Wuaueng.dll version 7.6.7601.18847. . . . . . . . . . . PASS
                This version is WSUS 2.0

Checking AU Settings
        AU Option is 4: Scheduled Install . . . . . . . . . . . PASS
                Option is from Policy settings

Checking Proxy Configuration
        Checking for winhttp local machine Proxy settings . . . PASS
                Winhttp local machine access type
                        <Direct Connection>
                Winhttp local machine Proxy. . . . . . . . . .  NONE
                Winhttp local machine ProxyBypass. . . . . . .  NONE
        Checking User IE Proxy settings . . . . . . . . . . . . PASS
                User IE Proxy. . . . . . . . . . . . . . . . .  NONE
                User IE ProxyByPass. . . . . . . . . . . . . .  NONE
                User IE AutoConfig URL Proxy . . . . . . . . .  NONE
                User IE AutoDetect
                AutoDetect not in use

Checking Connection to WSUS/SUS Server
                WUServer = http://serverutil
                WUStatusServer = http://serverutil
        UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS
        Connection to server. . . . . . . . . . . . . . . . . . PASS
        SelfUpdate folder is present. . . . . . . . . . . . . . PASS

Press Enter to Complete
-----------------------

It shows on this report I am running WSUS 2.0 but the Help on the WSUS server indicates ver 3.2.7600.226.

I have a Dell SonicWall.  I may have adjusted a rule or setting since then but not sure why something would have changed on the internal side.  One domain.  

Group policy looks ok.  I am not using the stated port 8530 on wsus server name.  When I did the diag tool gave me the:

VerifyWUServerURL() failed with hr=0x80072efd

error message.

WSUS is showing my PCs not updating.  I ran the suggested tool that checks for the communication between client and wsus and the passed (ropl.msc ?? cant remember).

Clients show green "No Updates" when you go to the Windows Update screens.  I think it is either group policy or the SonicWall.  The updates are downloaded and ready to install according to WSUS. I rebooted the WSUS server. Please advise.
cobmoIT ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

h1r0Commented:
Where is the wsus server? In the dmz?
0
Seth SimmonsSr. Systems AdministratorCommented:
are the updates approved for the group(s) these clients are in?
what is the last date the systems show as reported?
0
cobmoIT ManagerAuthor Commented:
The WSUS server is on the same side as the rest of the network. No DMZ.  The updates are approved accordingly.  Nothing has been modified on the WSUS server.  There have been changes on the SonicWall over the past two months but Im not sure why the SonicWall would care what the internal PCs are doing talking to the WSUS server.

The last update was June 10 on my PC.  In the Synchronization of the WSUS server it shows that it is all green and shows 214 updates in July plus another round in July.
0
DonNetwork AdministratorCommented:
"It shows on this report I am running WSUS 2.0 but the Help on the WSUS server indicates ver 3.2.7600.226."

WSUS 2.0 is the version of the tool

"I am not using the stated port 8530 on wsus server name."

From your WSUS console when you highlight servername(just under Update Services)..what port does it say under connection???

Is  http://serverutil the actual name of your wsus server ??

0x80072efd is  99% of the time a misconfiguration of GPO
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cobmoIT ManagerAuthor Commented:
Im awarding the GPO issue because I rebooted the wsus server, ran the cleanup wizard, and also ran a gpupdate /force and this morning everything is updating as usual.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.