RDS connection does not prompt for login credentials, when launched 2nd time on same computer.

Hi
On a client, connecting to an 2012R2 RDS server through rdweb, I have a serious security problem.
The user logs in to the session, getting prompted for credentials.
The user logs the session using ctrl+alt+end.
Then he goes for coffee.
Another employee walks by, and clicks the session Collection. He gets no prompt for password, but connects to the other session, and at the same time magicly unlocks the locked session without knowing the password?!
LVL 2
mathiesen-dataAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kash2nd Line EngineerCommented:
have you got appropriate security GPOs enabled.

look here >>> https://technet.microsoft.com/en-us/library/cc730945.aspx

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.