Trying to compile syslinux 4.03 on Ubuntu 14.04

After unpacking the tar.gz and running make in the root folder, I will after some compiling get this message:
linux/ext2_fs.h: No such file or directory.

I can find that file in /usr/src/linux-headers-3.19.0-25/include/linux, and I am assuming that the make process is not finding it. I tried making a symbolic link from /usr/src/linux-headers-3.19.0-25/include/linux to /usr/src/linux, but that did not change the outcome. I also tried linking to /usr/src/linux-headers-3.19.0-25/include and /usr/src/linux-headers-3.19.0-25.

I will use it to make a bootable usb, and it seems that I have to have the 4.03 version of syslinux to make a bootable vmware esxi install usb. Syslinux is mentioned in the following link, but nothing about setting it up: http://pubs.vmware.com/vsphere-55/index.jsp?topic=%2Fcom.vmware.vsphere.install.doc%2FGUID-33C3E7D5-20D0-4F84-B2E3-5CD33D32EAA8.html

Any suggestions?
LVL 2
itniflAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gheistCommented:
Can you post full error message you get from GCC?
Usually it looks in /usr/include/./linux/ext2_fs.h which should be populated mainly by glibc headers (though no glibc may be used for syslinux)
Duncan RoeSoftware DeveloperCommented:
What is the URL of the tar.gz that you are using? I'll give it a try when I get time
itniflAuthor Commented:
Here are the outputs from make and make install.
Adding the source for syslinux also. Don't remember where I got it.
outputMake.txt
outputMakeError.txt
outputMakeInstall.txt
outputMakeInstallError.txt
syslinux-4.03.tar.gz.pdf
Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

gheistCommented:
make[2]: nasm: Command not found
make[2]: *** [realmode_callback.o] Error 127

FIX# apt-get install nasm

btw 4.03 is just retired
https://www.kernel.org/pub/linux/utils/boot/syslinux/

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
itniflAuthor Commented:
VMWare specifies two versions of syslinux as compatible with theyr usb scripted boot solution, one is 4.03. I used 4.05 and it worked, but I still want to be able to compile 4.03 just in case of future problems with 4.05. I ran into the nasm problem before, and I did try to install nasm. I tested the install in the wrong vm last time I posted, so nasm was missing. Posting new longs after nasm install.
outputMake.txt
outputErrorMake.txt
outputMakeInstall.txt
outputErrorMakeInstall.txt
gheistCommented:
/bin/sh: 1: upx: not found
/bin/sh: 2: upx: not found
../libinstaller/fat.c: In function ‘syslinux_check_bootsect’:

FIX# apt-get install upx

btw you can run make -s and output stderr only...
itniflAuthor Commented:
Ok I used the -s switch now. Here is the output. How do you go about reading those? I searched for error and "not found" but could not find anything new.
outputMake.txt
outputErrorMake.txt
outputErrorMakeInstall.txt
gheistCommented:
Just look around the end of build log:
/bin/sh: 1: cd: can't cd to syslogo.ppm.gz

1) configure build without boot logo
2) provide boot logo
3) read the README file from distribution about what are build requirements.
itniflAuthor Commented:
Sorry for the late reply.
I found no information on how to do any of these things, the README file is very general and provides no real how to information. Syslinux has a website, http://www.syslinux.org/, but I can't find any relevant information on the problems I am facing here.
gheistCommented:
You already have syslinux.com that you can invoke from freedos
Is it so hard to create 1x1 pixel ppm and gzip it?
itniflAuthor Commented:
You want me to invoke syslinux.com from freedos? What does that even mean?
No it is not hard to gzip a 1x1 pixel ppm, but this error message that you picked out at the end is not telling me that I need to do exactly that. You make an assumption from previous knowledge or experience that I do not have. I have had no use for compiling syslinux before or using ppm files(in any way, so ppm meant nothing to me until now), and there are no descriptions anywhere on the requirements of the build or what the different parts are. This is like trying to make an apple cake, then you call the apples xyz instead of apples, and I come from a place on earth where apples are never heard of. So how do you think apple cakes gets made under such circumstances?
gheistCommented:
You can make bootable ESXi CD in powerCLI out of bundle zip.
itniflAuthor Commented:
Yes I know, and I'm already using Syslinux 4.05 that I got with aptitude to make bootable USB via Linux. It works, but I wanted to know how to compile the 4.03 version that VMware says is required. I guess I should not care as long as my bootable USB works with 4.05 and this compiling journey seems to get me nowhere. For different reasons, the CD version of this all is not in use right now.
itniflAuthor Commented:
Thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.