Domain user is not able to RDP to his PC, Gets error "To log on to this remote computer, you must be granted the Allow on through"

Hi

We have Windows 2012 DC and windows 7 clients   and a Windows 2012 RDP server in our network.
I have a user who likes to RDP into his PC.
This user is able to RDP into the RDP server successfully.  But from the RDP server if again RDP to the user PC, I get a message
“To log on to this remote computer, you must be granted the Allow log on through Terminal Services right. By default, members of the Remote Desktop Users group have this right. If you are not a member of the Remote Desktop Users group or another group that has this right, or if the Remote Desktop User group does not have this right, you must be granted this right manually”

I logged into the user PC (that needs to be RDP) and configured two things
Firstly: I went to the system –advanced settings-remote- enabled allow connections from computers running any versions of Remote desktop.
Secondly: On the user PC –Gpedit.msc- Computer configuration-Windows settings-security policy-Local policy-User rights assignment-Allow log on locally – Added the user.
In our AD on the built in OU I can see a Remote desktop users group and I added the user here as well, but still I get the same message.

Any help to sort this much appreciated.

Thanks
lianne143Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

OriNetworksCommented:
Add the user to the local Remote Desktop Users group
0
OriNetworksCommented:
This would be on the workstation they are trying to connect to, not the server.

Start->run->control userpasswords2
click ok.

Click Advanced tab, click Advanced button. and select groups.
Right-click the Remote Desktop Users group and select Add to group.
Click OK to add the user.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lianne143Author Commented:
On the workstation the user  trying to connect I did Start->run->control userpasswords2
click ok.

Click Advanced tab, click Advanced button. and select groups.
Right-click the Remote Desktop Users group and select Add to group.
Click OK to add the user.

But still the same message is popping up , please help.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

OriNetworksCommented:
Unless you have modified the default security policy of the computer, this would already grant the user access. You can check this by:
on the user PC –Gpedit.msc- Computer configuration-Windows settings-security policy-Local policy-User rights assignment-Allow log on through Remote Desktop Services  

By default Administrators and Remote Desktop Users groups should be in there. If those groups are still in there you may want to restart the computer and try again.
0
lianne143Author Commented:
After adding the user to Allow log on through Remote Desktop Services
it is working now,

Thanks so much  and a big hug to OriNetworks
0
lianne143Author Commented:
Finally the on the workstation the user  trying to connect it had two monitors. Is it possible to scroll \ see the second monitor  on the RDP session.

Thanks
0
OriNetworksCommented:
Only Windows 7 Ultimate and Windows 7 Enterprise Editions support multiple monitors through RDP. If additional information is required, please open a separation question for the new topic.
0
lianne143Author Commented:
Many thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.