CentOS 7 NFS

I mounted the shared but when I try to enable NFS service I keep getting following error -

[root@FCNAS /]# service nfs start
Redirecting to /bin/systemctl start  nfs.service
Job for nfs-server.service failed. See 'systemctl status nfs-server.service' and 'journalctl -xn' for details.
[root@FCNAS /]# systemctl status nfs-server.service
nfs-server.service - NFS server and services
   Loaded: loaded (/usr/lib/systemd/system/nfs-server.service; disabled)
   Active: failed (Result: exit-code) since Wed 2015-08-26 17:20:58 MST; 2min 56s ago
  Process: 21429 ExecStartPre=/usr/sbin/exportfs -r (code=exited, status=1/FAILURE)

Aug 26 17:20:58 FCNAS exportfs[21429]: exportfs: /etc/exports:1: unknown ke...h"
Aug 26 17:20:58 FCNAS systemd[1]: nfs-server.service: control process exite...=1
Aug 26 17:20:58 FCNAS systemd[1]: Failed to start NFS server and services.
Aug 26 17:20:58 FCNAS systemd[1]: Unit nfs-server.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.
[root@FCNAS /]# service nfs start


On Putty session it shows following error -

 directory.
[root@FCNAS bin]# service nfs restart
Redirecting to /bin/systemctl restart  nfs.service
Job for nfs-server.service failed. See 'systemctl status nfs-server.service' and 'journalctl -xn' for details.
[root@FCNAS bin]#
LVL 4
pchettriIT DirectorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dan CraciunIT ConsultantCommented:
Looks like a bad syntax in /etc/exports. Please post the content of that file.

HTH,
Dan
0
pchettriIT DirectorAuthor Commented:
10.0.0.0/24(rw,sync,no_all_sqash,no_root_squash)
0
Dan CraciunIT ConsultantCommented:
So where's the shared directory?

The syntax is
<export> <host1>(<options>) <hostN>(<options>)...

Where <export> is of the format /path/to/folder

And no_all_sqash should be no_all_squash
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

pchettriIT DirectorAuthor Commented:
share directory is in /mnt/VDPNFS/NFSshasre. I was able to get VDPNFS mounted and access it from ESX.  I may have to change 10.0.0.0/24(rw,sync,no_all_sqash,no_root_squash) to list of ESX IP address and vcenter in 4 lines instead of letting it accessed by entire network.

Thanks for your help it was spelling mistake on sqash that was squashing me.
0
pchettriIT DirectorAuthor Commented:
One more thing that I was surprised with is the 12 tb partition on Centos showing as only 10.82 tb. It chews more than a 1 tb to present as datastore in VMFS
0
Dan CraciunIT ConsultantCommented:
I don't use VMware, so I have no idea.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.