Print jobs process through print queue, show status as printing and then disappear without printing

Here's the environment -
Win7 Home
HP OfficeJet Pro 8615

-Issue
After installation, printing a test page (or any printing) results in the print queue receiving a file like usual.  The status of the file goes from spooling to printing and then disappears from the queue but the printer never prints.

-Things tried so far to save some time on solutions.
Malware scan removed 1,800 benign issues
Updated OS
System restore to when it worked (three days back) failed the restoration
HP Drivers removed and reinstalled multiple times
Scanning on printer works from desktop without issue
HP Print and Scan Doctor successfully prints a page directly from the printer (printer status sort of thing)
Scan Doctor prompts to uninstall and reinstall drivers (tried multiple time)
Printer works fine when installed and run from another computer
Used Kyocera "Deleter" to remove orphaned files and as a guide to remove orphaned entries from registry
Used most current available drivers from HP for all of the above
Confirmed that both the printer and fax are assigned virtual ports (USB001 and USB 002) after install
Confirmed security settings/permissions for printing

-Notables
System owner reported it worked fine until she was attempting to add printer at another location (system is laptop).  During that new install (from disk), the system shut down (black screen and she had to restart) during the install.  When she first contacted me, Driver Manager or something similar was on the system and she was being prompted for some sort of a key to proceed with the install by that software to install the drivers.

Per info from HP forums, printer was manually removed from ControlSet, ControlSet1 and ControlSet2 after uninstall via install package.  Still no joy.

Found one posting about replacing a (sorry, not correct name) hpxxxrender.dll from the spooler area in System32.  No joy.

It appears that something is /has been damaged in the transport from the spooler to the printer.  This one really has me stumped and any help would be appreciated.
AriesUpNorthAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TemodyPickalbatros, IT ManagerCommented:
Sounds like a misconfigured port
arnoldCommented:
Check printer log to see:
Did it receive the print job
What status..

Does the printer have a static ip?
Or the printer indirectly connected to the computer via usb?
nobusCommented:
i would run sfc, or a repair install; since it looks the OS is damaged
http://www.sevenforums.com/tutorials/3413-repair-install.html            REPAIR
http://www.sevenforums.com/tutorials/1538-sfc-scannow-command-system-file-checker.html         SFC

if this does not help - try making a new user account - and test from there
Starting with Angular 5

Learn the essential features and functions of the popular JavaScript framework for building mobile, desktop and web applications.

AriesUpNorthAuthor Commented:
Thanks all!  Here's an update.

1)  SFC completed again without any issues.
2)  Created a new user, downloaded a fresh set of drivers, installed, same result.  Guess that means were looking at something messed up in the OS or some HP component that's hammered that isn't getting replaced on reinstall.
3)  Temody - regarding mis-configured port; may be the issue, but no option to configure the virtual USB port created at time of install (clicking "configure port" for the printer responds with dialogue box stating nothing can be changed).  Are there tools to rebuild/clear that info from the system?
4)  Anyone aware of a tool that will actually remove ALL instances/references of an HP Printer install?  I did a scan through the registry with the printer removed and found many references, including several in the MSI's and some of those appear to be the driver installs.  I really don't think my re-installations are clean given I see all those references in the registry when the printer isn't there.  Note that I did use the Kyocera Deleter tool and it did find and remove several orphan dll's after one of the uninstalls.
5) With the printer uninstalled, there were many folders in Program Files, Program Files x86 and in ProgramData with the name of the printer.  These include .bin folders along with others.  Again, I'm questioning if there's some artifact of the failed install that resulted in damaged files being placed on the system that are not replaced in the re-install process because they are left behind after an uninstall?  

Thanks again...restoring the system to out-of box is starting to look like the only viable option unless there's some tool/utility that will actually purge everything HP put in during install out of the system.
arnoldCommented:
Check what the printer logs say.
Your issue might be that the job is queued up on the printer, or it is hitting a rule on the printer.

Use the printer menu and print its config..

You are looking at one end, source and having nothing coming out of the printer and you are supposing that the issue is with the source.  It could be on the printing side and a log should reflect.  Since you did not mention the issue is not a driver related error that the printer reflects an error with each attempt.  Recheck your printer properties/preferences for spooling settings. Does your eventvwr reflect any spooling error under application or system?

Disable spooling. Are your spooling rules to print after all pages have been received or to print with the first ..........

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mal OsborneAlpha GeekCommented:
I have seen an HP printer do that just because of mismatched paper size. Check you are not trying to print letter size on A4 or something.  

Caught me for a while the first time too.
hdhondtCommented:
The OfficeJet Pro 8615 is a PCL3 printer. PCL3 is not a printer language like PCL5 or PostScript - it relies on the PC's graphics engine to convert the page into dots on the paper. If a printer like that receives invalid data it tends to completely ignore it. That prompts this suggestions:

1. Make sure you are not using a PCL5 driver
2. If the driver is corrupt, the same problems may occur - I know you have completely reinstalled, but try uninstalling from the Control Panel
AriesUpNorthAuthor Commented:
Thanks to all for the suggestions.  The client decided to take the shortest path and restore the system back to out of the box and rebuild back to current.  

Before that decision, I did try Arnold's suggestion to disable spooling and check logs.  I am marking that suggestion as the accepted solution because 1)  Printing direct to printer failed with an error and 2)  the printer logs showed different errors than direct print attempts for each attempt to print through the spooler.  Though the answer isn't truly known, that was seemingly taking me on the right path.

FWIW, all print functions were normal with this computer/printer after the system rebuild from the integrated recovery partition.  

Again, thanks to all!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.