I recently demoted one DC exchange services not starting

I recently demoted dc n seized the only one dc.
Now exchange services not starting even after giving the correct dns address in network card.

How to make server use the remaining dc?.
Your help is appreciated
LVL 31
MASEE Solution Guide - Technical Dept HeadAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DeepinInfrastructure Engineer Commented:
Have you rebooted the Exchange since changing DNS?

also what eventlog errors are you getting
arnoldCommented:
Or restart the exchange services.

There are step by step guides to deal with a process where exchange is involved.

Usually, one does not denote until after the roles have been transferred as well as verifying the AD is synchronized.
At this point restarting the services should work.

Is the error relates to the credentials used for the services?
MASEE Solution Guide - Technical Dept HeadAuthor Commented:
I tried switching to new dc n exchange restarted.
after 15 min suddenly database become offline.
I found the new dc is not responding. I seized the one which is healthy.
and chabnged the dns in exchange still services not starting. even network services not starting
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

arnoldCommented:
How many tes did go through seizing?

Double check the DC that remains and make sure it has GC ............


Other than saying it stops working or not responding you are not providing what might be going on.  Check event log and exchange console to see what it is reporting. Which component fails, the Dag?
MASEE Solution Guide - Technical Dept HeadAuthor Commented:
I restarted now and now I m getting blank desktop screen cannot see the icons

seized all the 5 roles and It is a GC as well

BTW exchange and current DC is running VM
MASEE Solution Guide - Technical Dept HeadAuthor Commented:
One more thing I tried to check the database state.
Almost all the database is in dirty shutdown. will it be a problem for not starting information store?

bcz sometimes activedirectorytopology  service starts but not informationstore.
It shows starting but never starts

This is one error from event viewer
"Unable to initialize Microsoft information store "
Amit KumarCommented:
Check primary DNS in your DC it should be the one which is running. if not then put correct dns and reboot dc then run below

also run dcdiag /s <servername> /f:c:\dc.txt
Zacharia KurianAdministrator- Data Center & NetworkCommented:
BTW exchange and current DC is running VM

What version of VMware?
Have you upgraded your VM's Version?
Have you installed the VMware tools?
Make sure to use VMXNET3 and make sure you don't have time drifting in your VMs.

Run full health check on your PDC and make sure you don't miss anything. Do the same on your Exchange too.

Zac.
arnoldCommented:
Hyper-v based vms with the host a domain member server.
MASEE Solution Guide - Technical Dept HeadAuthor Commented:
I recovered the server using recoverserver switch
Now I cannot access any other domain account except root domain accounts
arnoldCommented:
On the DC, can you list/verify status of each user,computer account.  Using ntdsutil .....


It us still not clear what the AD was at the time of the seizure.

How soon after you joined the VM DC did you decomition the other DC?


Where are you trying, usually only domain admin accounts can login into a DC.
MASEE Solution Guide - Technical Dept HeadAuthor Commented:
What I meant is now mailboxes of the root ddomains started working. But mailboxes of other domains not working.
Even I cannot disable or create.
Can anyone suggest?
arnoldCommented:
Does your DNS server have info about all the domains?
MASEE Solution Guide - Technical Dept HeadAuthor Commented:
Please find the attached file
Added as secondary zone for all the other child domains

When I type nslookup -q=srv _ldap._tcp.dc._msdcs.childdomain.com
I am getting the DC address of child domain
EE.png
arnoldCommented:
Person has to forcibly recover exchange which required the deletion of the DAG ADSI entry.

https://technet.microsoft.com/en-us/library/dd979799%28v=exchg.150%29.aspx#DAGforSiteResilience
Recreating a new DAG entry using a new DAG cluster account allowed the mailboxes to be mounted.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MASEE Solution Guide - Technical Dept HeadAuthor Commented:
Many thanks to Arnold
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.