Flash content not working in IE 11 on Windows 8.1

CenturyLink page in IE 11 Flash content icons not showing correctlyCenturyLink page in Firefox Flash content icons showing correctlyI provide IT assistance for a friend. She has a Dell Dimension desktop with Windows 8.1. Here is a chronology of a problem she asked me about. Text in quotes is from her. See attached screen shots illustrating the problem in IE (Flash content icons are on top of each other and are not images but just placeholders) and that it looks correct in Firefox. BTW, the user wants to use IE. She said everything was working fine with IE and the problem just started on 8/12/13.

8/13/15 7:10 pm: "Since yesterday, a little box keeps popping up in the upper left hand corner of my screen that is titled "Adobe Flash Player" and then in the box it says action script errors and lists a bunch of things.  I have 2 choices of things to do:  Dismiss all, or Continue.  I've tried both.  Both make the box disappear, but it just comes back a few seconds later.  While the box is there, nothing works on my screen . . . can't type, use the mouse, etc.  It freezes my screen until I click one of those choices."

8/13/15 7:17 pm: "This is the error that Adobe says I have and what the Adobe web site said about it:  
2148      SWF file %1 cannot access local resource %2. Only local-with-filesystem and trusted local SWF files may access local resources."

8/13/15 10:42 pm: ".  I found the "security settings" panel on Adobe Flash Player site, and decided to "allow" the web address that caused the error to pop up.  I have no idea what this web address is but since I allowed it, the pop up window has disappeared.  The web address of the problematic site is:
http://p.jwpcdn.com/6/12/jwplayer.flash
This is the same web address that others on the Adobe chat site were complaining about.  Who knows who they are, but they seem like an address that wants to run video on my home page.  So, I allowed it.  My malwarebytes found NO issues or threats."

8/16/15 2:03 pm: "So, I was online with a tech guy Friday and Sat, and he had me change my browser, and ta da, no more pop-ups.  I'm using Firefox now.  But, I want to be able to use Internet Explorer, too, and the pop-ups are still there. He gave me a set of instructions to get rid of malware in my browser (he said since Firefox works without pop-ups, that means my PC is not infected, it's the browser that is and that's why Malware bytes and Windows Defender didn't find anything in my computer).  Well, the instructions left me hanging on about the first step as the options in the window that he said would be there weren't.  So he gave me some malware advice web sites to check and one of them suggested resetting Internet Explorer.  I followed that reset procedure, and now Internet Explorer doesn't work at all."

This morning I did a TeamViewer remote session and tried some things, none of which resolved the issue.
1. I removed and re-added IE using this procedure:
     http://windows.microsoft.com/en-in/internet-explorer/install-ie#ie=ie-11
2. I tried installing the Flash player version specific to IE (Active-X version) from adobe.com and got an error "Insufficient privileges" even when I ran as administrator and said YES to UAC (user is an administrator).
3. Checked add-ons and Shockwave/Flash is enabled.
4. If I go the the "check Flash" Adobe page the Flash animation works and it says she has the latest Flash for IE, Firefox, Chrome etc.

When I went to adobe.com in IE on her computer instead of the normal layout, all the text was arranged in a column running down the left side of the screen and there were no graphics. I had to use Firefox to be able to navigate to the download page for Flash Player, so it isn't just the CenturyLink page that is nor working correctly.

Thanks,
Don
donanderAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Flash for Windows 8, 8.1 and Windows 10 is built into Windows and not separately installable. Make sure Windows updates are all up to date.  I also disable Script debugging on my IE 11 setup.

Try resetting Internet Explorer. IE, Tools, Internet Options, Advanced and click on Reset. Select both sections which means personal settings and passwords will disappear.

If this does not work, and because viruses or other malware may be implicated here, set up a new, test, Windows User Profile (Account). Log into the new account and test.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
donanderAuthor Commented:
The user had previously reset IE and it didn't resolve this issue but since then I removed and added back IE 11. Now when she reset IE it fixed the problem so I am accepting this comment as the answer.
0
JohnBusiness Consultant (Owner)Commented:
Thanks for the update and I was happy to help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Adobe Flash

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.