Removed disks a Cluster (Windows Server 2008R2) shown in disk manager as unformatted partitions - URGENT

I removed disks from Failover Cluster, because I can't put them online. After removal, I can put them online through Disk Manager, but the partitions shown to me as unformated.
I need to recover this data.

Help!
MicronasAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
What and how were the disks setup?  Usually in a cluster the disks are presented only to the active node.

Where did you remove them from?

You might have to use tools loath will scan the disks to restore the data/partitions.  If these were part of a raid you would need to reconstruct the raid before you could see the data.
0
MicronasAuthor Commented:
Hello Arnold,

Excuse-me for a long time to answer, but i was sleeping after many hours working. So, I answer your questions:

This problem occured in the last node of cluster.

The disks are presented by iSCSI storage system.

A removed them of Failover Cluster Manager, I can see the partitions on Disk Manager, but when I try to access, I receive an error message that says the unit needs to be formatted.

More ideas?
0
arnoldCommented:
As I said, usually, the shared resource is only available to the active node in the cluster.

When you said you removed meaning you disconnected them via iscsi and then reconnected them.

Check the source to make sure that the lungs that are presented to your system are actually online there. The disk being brought online might mean the iscsi target is presented to your server, but the underlying storage on the iscsi server is offline.

If you are using freenas or openfiler as the iscsi server, look at lvmdisplay to see whether the storage space are reflected online. If they are reflected offline, you would need to run lvchange -ay to bring the lv online.
0
MicronasAuthor Commented:
Hi Arnold,

Thank you for your attention. I solved the problem starting the cluster with the command “net start clussvc /fq” forcing the startup without “quorum”. After I add disks again to the cluster, afterwards the problem disappeared.

Thank you!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MicronasAuthor Commented:
I solved the problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.