notepad++ spellchecker stopped working on windows7

notepad++ spell checker stoped worked

I go to update and no updates available (so I think I am using latest version)

I restarted notepad++
do not tell me to restart computer because I have many programs running
LVL 1
rgb192Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jmcgOwnerCommented:
Last time I updated Notepad++ it noted that the spell checker was being moved to the disabled subdirectory because of a stability problem. I haven't researched the issue to see if a fix is soon to arrive.
1
adamdalgCommented:
Hello,  

Have you tried moving the DSpellCheck.dll from the "disabled folder" to the "plugins" folder?  Sometimes after updates this file can be moved.  The folders are found in your installation directory.
0
Michael-BestCommented:
Open Plugins
If Spell-Checker isn’t showing up on the list, open the Plugin Manager and check it from the Available tab and then click Install.

Reference:
http://www.groovypost.com/howto/notepad-plus-plus-spelling-extension-setup/
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

JohnBusiness Consultant (Owner)Commented:
Uninstalling Notepad++, run SFC /SCANNOW in an Admin Command Prompt. Now shut down the computer. Dead simple do. Start back up and install Notepad++.  Test and see if it works.

"Don't tell me to restart"  Sorry my friend, that is silly.
0
rgb192Author Commented:
sorry, as asked in the original question; I would prefer not to restart computer

this is popup window that appears when I go to topMenu-plugins-spellcheckerthis is popup window that appears when I go to topMenu-plugins-spellchecker

http://aspell.net/win32/
I do not know which to download for 64 bit windows7

and where do I place files
which folder?
and why are all the files old (2002)
0
JohnBusiness Consultant (Owner)Commented:
You should be able to use the 32-bit on a 64-bit machine. Notepad is likely 32-bit as well (like Office, Adobe, etc.)
0
rgb192Author Commented:
and plugin manager
spellchecker is not listed in available tab
only listed in installed tab
installed -spellchecker
I also clicked
reinstall
and restarted notepad++


from plugin manager settings:

Plugin Config path is:
C:\Users\Acer\AppData\Roaming\Notepad++\plugins\Config
Plugins in user's AppData directory are disabled - to enable in Notepad++ version 5.9.7 onwards place an empty file called allowAppDataPlugins.xml in the Notepad++ directory.
0
rgb192Author Commented:
any suggestions?
0
rgb192Author Commented:
any suggestions?  I restarted computer and did all Windows 7 updates
0
Joe Winograd, Fellow&MVEDeveloperCommented:
It's possible that all you have to do is move the file called DSpellCheck.dll from the disabled folder to the plugins folder. Using Windows/File Explorer or whatever file manager you prefer, locate the DSpellCheck.dll file, which is likely here on your 64-bit system:

c:\Program Files (x86)\Notepad++\plugins\disabled\

Then move it to here:

c:\Program Files (x86)\Notepad++\plugins\

That should do it. Regards, Joe
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cantorisCommented:
Whether you eventually get it working or not, the central issue remains that the developer of Notepad++ thought the spellchecker too unstable to continue using.  It's interesting that the DLL is 13 years old!  Maybe he deliberately made it so you can't reenable it.
It's not a Windows issue with your machine that needs action from you though.
1
Iain MacMillanIT Regional Manager - UKCommented:
Spell-checker was disabled in the last few releases due to reported Windows 10 issues, as my fellow experts have already mentioned.  

On my 6.8.3 install, i can see the Spell-checker file listed under Available, so you may be able to do a work-around since your not using Win 10.  Failing that, type carefully  :)
0
rgb192Author Commented:
thanks.
I copy paste correct answer in case this happens to me again


DSpellCheck.dll file, which is likely here on your 64-bit system:

c:\Program Files (x86)\Notepad++\plugins\disabled\

Then move it to here:

c:\Program Files (x86)\Notepad++\plugins\
0
Joe Winograd, Fellow&MVEDeveloperCommented:
You're welcome. I'm glad that worked for you. Regards, Joe
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.